I have setup the plugin to have working hours from 10am -

Hi, I have setup the plugin to have working hours from 10am - 8pm with two breaks between 12pm - 1pm : 4:30 - 5:30 and bookable times slots of 15 minutes.

When I click for an appointment, I can only see available time slots up to 5:45 instead of seeing them up to 8pm.

Any help on this would be grateful.

  • Michael Bissett
    • Recruit

    Hey @Infinite Design, hope you're doing well today, and welcome to WPMU DEV! :slight_smile:

    Could you enable Support Access to your site, so that I can have a closer look at your settings? The hours you mentioned sound find, but I get the feeling that there's something in the configuration here that's getting in your way.

    As for the enabling of Support Access, we've got a handy guide that you can follow right here:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please advise,
    Michael

  • Ash
    • WordPress Hacker

    Hello @Infinite Design

    I hope you are well today.

    When you selected working hours for Santa, you didn't make a working day. I have just tested making Monday as a working day and it worked fine. You need to select your working day like the screenshot.

    Secondly, you didn't have any shortcode for service providers, I have just put that. So select a service and a service provider and check the calendar.

    [app_confirmation] shortcode was also missing.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers
    Ash

  • Infinite Design
    • New Recruit

    Hi,
    Great, thank you.
    That works in my situation where I've disabled the the calendar navigation so only November and December are displayed.

    It means I only have to exclude 3 Monday dates from my display (as santa is only available between a set period in November and December :wink: ).

    Maybe adding a duration feature for services? so services can be set between two dates. As the only way to do this I've found is to set the working hours to 'no', and set the exceptional working days for the period... which was causing the original issue, as you need to have a working day set to fix it.

    Many thanks for sorting this out.

  • Ash
    • WordPress Hacker

    It means I only have to exclude 3 Monday dates from my display (as santa is only available between a set period in November and December :wink: ).

    You can disable any date, just go to Appointments > Settings > Exception and add the date in there :slight_smile:

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.