I have somehow lost

I have somehow lost my front page. At the moment, I have a most recent blog post. When I try to edit in Upfront, I get up to 26% loading and then stalling.

I can add more detail if needed, but this is the main problem.

  • Nithin
    • Support Wizard

    Hi John,

    Hope you are doing good today. :slight_smile:

    I checked your website, and I could notice the issue. Except the homepage, Upfront does load fine in other pages. It's odd that the latest post is being shown in your homepage. I'm getting the following error when I try to load the homepage:
    Uncaught TypeError: Cannot read property 'postId' of undefined

    This issue needs further attention, and I'm pinging one of the developers to give a closer look, either myself, or the developer will keep you posted asap. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • John
    • Site Builder, Child of Zeus

    Thanks for looking into this. The last thing I did was try to rebuild our "contact" page. It was displaying as a (maybe duplicate) of the home page. So I completely rebuilt the page. And then all hell broke loose.

  • Kasia Swiderska
    • Support nomad

    Hello John,

    We are still waiting for developers feedback - I tried to load home page from another page (you can do that when opening Editor on different page and then clicking Upfront logo in sidebar), but it didn't worked. Copy of the page where I loaded Editor was only showing - this is bit strange and it needs to be consulted with dev.

    kind regards,
    Kasia

  • Denitsa
    • WordPress Warrior

    Hey there John,

    It seems that requests to the server are failing in some situations when trying to load Upfront on the frontpage. Developer's advise on this is to try and reset the homepage layout altogether. You can do that by going to Upfront -> General, under Debug Options choosing Home page from the drop down and hitting the Reset layout button. Keep in mind that it really will reset your layout, so make a backup just in case.

    After doing that, could you please make a basic plugin conflict test? To perform it, please follow all the steps described on a flowchart in this article (you may need to scroll the page down a little):
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Basically, after you disable all your plugins and you visit your site does the problem persist? If no, try activating those one by one, refreshing your site's page until it stops working again. Note the last plugin you activated before the issue surfaced again.

    Let us know how it goes!

    Cheers,
    Denitsa

  • Lindeni Mahlalela
    • Recruit

    Hello John,

    Thank you for your question.

    Resetting the layout of a page will only reset the layout of that page you have chosen on the drop down. But as Denitsa said, you should first backup your current layout before you can reset.

    If you feel you should backup your entire site to be on the safe side, you can try our Snapshot Pro, with it you will be able to backup your whole site and be able to restore it to a working state just in case, but as mentioned, resetting the layout of a page will only reset it for that page not others.

    I hope this answers your question.

    Cheers,
    Mahlamusa

  • John
    • Site Builder, Child of Zeus

    Thank you! I did indeed reset the homepage, which was easy enough to rebuild. I lost some of the content, but with Upfront, it was easy enough to rebuild most of it. Sadly, something else must have conflicted, because I ended up having to do it twice. No idea what that could be. Interestingly, my site is loading much faster, so something good came out of it.

    I'll see how it goes. Thanks again.

  • John
    • Site Builder, Child of Zeus

    To be honest, I have been a little leery. Almost all plugins are deactivated. I had to reset the homepage about three times. I am suspecting there was an issue with differing header menus that I have created over time. Resetting the page certainly sorted it out. But it meant I had to re-build the homepage each time. (not TOO big a deal) I am proceeding slowly and cautiously this time. I'll let you know if there are any direct issues with plugins.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.