I have started getting the error below on my local

Hi

I have started getting the error below on my local installation of wordpress. I get this message on every url that I visit.

Strict Standards: Redefining already defined constructor for class blog_templates in C:\NewUniServer\www\multisite\wp-content\plugins\blogtemplates\blogtemplatesfiles\blog_templates.php on line 63 Strict Standards: Redefining already defined constructor for class EasyTable in C:\NewUniServer\www\multisite\wp-content\plugins\easy-table\easy-table.php on line 68 Fatal error: Call to a member function get() on a non-object in C:\NewUniServer\www\multisite\wp-includes\query.php on line 27

Has anyone seen this before or know how to fix it?

Thanks,
Joe

  • Ash

    Hello there

    I hope you are well today and thanks for asking the question.

    This is not exactly error. You are using latest version of php. And the plugin is designed in a way so that it works in older versions of php too. This is a notice and this notice won't hamper your plugin :slight_smile:

    You can turn off this notice buy editing a line in wp-config.php. Please search for
    define('WP_DEBUG', true);
    and change it to
    define('WP_DEBUG', false);

    Please let me know if it is helpful and feel free to ask more question if you have.

    Cheers
    Ash

  • Ash

    Ahh then other plugin causing this problem. If you want to find out who is the culprit then I will request you to run a plugin conflict test.

    1. Rename the plugin folder to something else.
    2. Create another folder - Plugin
    3. Copy all plugins and enable one by one to check when the error returns.

    Also check with default WP 2012 theme, it could be a theme issue.

    If you want to just get rid of this thing without testing, then go to C:\NewUniServer\www\multisite\wp-includes\query.php line no 27 and change
    return $wp_query->get($var);
    to

    if(!is_null($wp_query)){
        return $wp_query->get($var);
    }

    Please let me know if it is helpful and feel free to ask more question if you have.

    Cheers
    Ash

  • Joe

    Hi Ash

    Here is a list of the plugins:

    Adults Only AVS for WP - Version 1.5.9 (this is from codecanyon.net)
    Affiliate Link Cloaker - Version 1.00.04 by Joe Brewer (Me!)
    Easy Table - Version 1.4 by Takien
    Google Analytics - Version 2.1 by Ivan Shaovchev, Andrey Shipilov, Hakan Evin (Incsub)
    New Blog Templates - Version 2 by Jason DeVelvis, Ulrich Sossou (Incsub), Ignacio Cruz (Incsub)
    NextGEN Gallery by Photocrati - Version 2.0.7 by Photocrati Media
    Pro Sites - Version 3.4.1 by Aaron Edwards (Incsub)
    Region Detect - Version 1.02.06 by Joe Brewer
    Simple Testimonials - Version 0.0.5 by PIXELovely
    WP Awesome FAQ - Version 1.2 by Liton Arefin

    Using theme Twenty Thirteen version 1.0

    Hope that helps!

    Joe

  • Ash

    Would you please do one more test for me? Just activate advanced theme switcher plugin (latest version) and deactivating all others with default WP 202 theme in WP 3.7. Now the you see the error?

    If yes, then please report to us. (i can't produce the error in my test site :slight_frown: )
    If no, then activate other plugins one by one and check activating which plugin is causing the problem.

    Please let me know.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.