I have sub dir, but example shows sub domain

In the set up example for domain mapping I am a little confused about the part in setting the A record. In says to enter name testsite.domain.org which is a sub domain. I have a sub directory which http://www.mydomain.com/client.

What should I enter into this name input? I have tried http://www.mydomain.com/client. but it says that http://www.mydomain.com is already reserved. I dont think putting in client.mydomain.com would work as this has not been created.

Thanks

  • aecnu
    • WP Unicorn

    Greetings keith_power6,

    Thank you for the great question - but I am not sure exactly what you are asking here.

    Can I have a screen shot please?

    The "A" record is used to direct the domain to your WordPress installation so that your WordPress installation can then resolve the domain name to the correct sub site which could be either sub domain install or sub directory install.

    Please advise.

    Cheers, Joe

  • keith_power6
    • New Recruit

    Hi Joe, thanks for the reply. Just now I have managed to resolve that particular issue. I was confused what steps were needed for the sub directory as there was little mention of it in the usage and I thought I might have to do a few more steps. But anyway it was a dns issue with the pizzaman.ie.

    Now I have another issue. pizzaman.ie now points to the ip of 193.36.43.50 which is myorder365.com. I have it mapped to myorder365.com/pizzaman.

    However now when I go to pizzaman.ie instead I get the page myorder365.com not not the subdomain.

    What am I am missing?

    Thanks again for any help
    Keith

  • aecnu
    • WP Unicorn

    Greetings keith_power6,

    Thank you for the screen shots and the additional input which indeed tells the tail of what or why this is not working.

    There is all kinds of things going on here to include after doing a reverse IP what appears to be a very over loaded server:

    Reverse IP Lookup Results—493 domains hosted on IP address 193.36.43.50
    Web Site
    4thfloorforphoto.com
    4x4trials.com
    ababu.ie

    And definitely not a dedicated IP by any means.

    As mentioned in the screen shot from post:
    https://premium.wpmudev.org/forums/topic/i-have-sub-dir-but-example-shows-sub-domain#post-334466

    And I quote:

    If your domain name includes a sub domain (which it does) then you can add a CNAME for that hostname in your DNS pointing at this blog URL.

    Therefore pizzaman.ie should have a CNAME record pointing at myorder365.com/pizzaman which in the dns records you posted it does not exist.

    This is all messed up though I am trying to help with the way it is because there should not be any DNS records on the server, the CNAME should be coming straight from the domain name registrar.

    In addition, causing complications, the main WordPress installation is not in the root of the main domain ingemit.com so WordPress is not resolving the DNS as it should be doing rather then the server DNS itself.

    You could also possibly send the CNAME to myorder365.com and WordPress will resolve it.

    The "A" record does not work because it is not a dedicated IP.

    Please advise.

    Cheers, Joe

  • Timothy
    • Chief Pigeon

    Hello, hope you're well!

    How's things going now, we haven't heard from you in a short while and as such he thread became marked as "Resolved".

    If you're still in need any help then please feel free to reopen or create a new thread as needed for any issues.

    Cheers.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.