I have tried the sanpshot plugin a number of time and it

I have tried the sanpshot plugin a number of time and it fails every single time, on the loginlockdown tables.

since limiting the number of login attempts is critical, there must be a fix for this. Can anyone please provide.

  • kiteg2

    backupbuddy = backupcreated
    backupcreator = backup created
    wpbackup = success

    snapshot = failure, failure,failure.

    http://www.screencast.com/t/gKXjrSN9gLm
    http://screencast.com/t/6IxeZSK7hY

    WordPress Version 3.8
    PHP Version 5.4.7
    MySQL Version 5.5.27
    Is Multisite No

    How large are they? How much memory are you letting Snapshot use.
    I did not know I needed to be a rocket scientist.

    All that information is needed to help determine the exact issue
    I am happy to help but you have to give me instructions you need for me to help you.
    almost every other plugin I have tested works fine, so I have no idea how or where to do/get what you need.

  • Paul

    @kiteg2,

    The error shown on the second image you provided is when snapshot tries to run the SQL command 'DESCRIBE <tablename>'. This is needed so the CREATE TABLE back of the backup can be included.

    Not really sure why/how the other backups tools can get past this needed information.

    Couple of questions.

    1. I know the table is important. But if you do not include this table does the archive complete?

    2. Do you have access to phpMyAdmin or something to access your database? Usually via your hosting control panel. Try running 'DESCRIBE <tablename>'. Obviously where '<tablename> is the actual table now from the error. See if you get output.

  • kiteg2

    Ok thanks that got me somewhere that might be helpful

    here is a screen cap of part of the log file
    http://screencast.com/t/7g8ns8XdEcKJ
    as you can see when it hits those tables it self destructs.

    Thanks for your suggestion to check without those tables. Yes I got a complete backup of all files and tables without those two tables mentioned.

    when trying describe: I get this "You have an error in your SQL syntax; check the manual that corresponds to your MySQL"

    tried with <> ' ' " " '< >' ; and other variations, got an error on every one I tried.
    can you shed some light on this? and I will try again

  • Paul

    @kiteg2,

    Glad you got that DESCRIBE figured out. Sorry I had entered the back tick but our system convert those to single quotes. You can actually leave theme off and just do DESCRIBE <tablename>

    Thanks for your suggestion to check without those tables. Yes I got a complete backup of all files and tables without those two tables mentioned.

    Great! Glad we are getting somewhere. Onward.

    Does that help?

    Not really. I was hoping there was something wrong with the table. Wait there are tables (plural)? I only see the one table in your last screencast image.

    The strange page is snapshot will run the describe on each table when building the listing with the checkboxes. If the describe fails on the first one you would not even be able to select the table checkbox to be included in the backup. So not sure how the second describe is failing.

    Maybe try doing a snapshot just with that one table that is causing snapshot to stop.

    Or maybe direct access to your site to I can help figure out what is going on. But hold off on that for now.

  • kiteg2

    Great idea, I will try and just "snapshot" the questionable tables.
    Might shed some light.
    would seeing the log file help at all?
    I'm testing on a local at present. there is a live site, but I am backing up manually at present, I have other plugins that work, but I don't like them.

    I like the look and feel of snapshot, so would really like to help figure out what this is. win/win for everybody if we can

  • Paul

    @kiteg2,

    would seeing the log file help at all?

    Sure, Can you upload it to somewhere like Dropbox and provide the link and I'll download. Feel free to replace sensitive attributes like paths and such for security reasons. I'll be glad to take a look though I did see the image you provided and I know where snapshot hits an error it just dumps out all variables. Not easy to interpret via a screenshot. But the root issue is snapshot is stopping because it can't access the table. Not sure if the process which owns the table is locking it of something. Snapshot does tend to be somewhat over sensitive. In that for the slightest issue it just stops and reports. Better than then something was assumed to be correct and you find out later the backup was not correct.

    So do you know what is creating those tables? Is this via another plugin? Maybe I can try running it on my own development site to see if I can figure out why snapshot is having trouble with it.

  • kiteg2

    Ok good news. I found the issue. Login lockdown had a code error, after a lot of messing about cleaning the database, removing tables, etc, I was able to download the plugin again, confirm it did not have code errors.

    reinstall and check the database for errors, which did not show up and then snapshot worked perfectly.

    Thanks for all your help. Really appreciate it.

    Hope you had a fantastic Christmas.
    Cheers
    Graham

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.