I have trouble

Hi,
I have trouble resolving this megasage
"gzip is not working properly:

- Your server may not have the "deflate" module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX)
- Another plugin may be interfering with the configuration
If re-checking and restarting does not resolve, please check with your host or open a support ticket with us."

i followed al the instructions and contacted my hosting provider. they told me that there is gzip compression on pages of my website. why i still get this massage?

Grtz Vincnet

    Nazmul H. Rupok

    Hi there,

    Hope you are doing well today! We have been reported similar issues and most of the cases, we have found the "deflate" module was not enabled on host which was causing the issue. Since it's enabled according to your host, there might be a plugin conflict if you have any security plugin installed. If you could try de-activating all other plugins except Hummingbird and see if it works then so we can eliminate a plugin conflict.

    Let us know how it goes. If you are still experiencing the issue after the above suggestions, can you send in your FTP so we can investigate further?

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Please visit our private Contact page and complete the form with the following information:

    Subject: "Attn: Nazmul"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    **If you keep support access active then no need to send in wp-admin"

    - FTP/SFTP credentials
    host
    username
    password
    (and port if required)

    Have a nice day. Cheers!
    Nazmul

    Vincent

    Hi Nazmul,

    Thanks for your response. I have tried all the above with no success, however all is setup now.
    what we (hosting and me) did was removing hummingbird completely and all the leftover lines in the .htaccess file and put in the code below. installed hummingbird again and run the test. all good!

    <IfModule mod_deflate.c>
      # Compress HTML, CSS, JavaScript, Text, XML and fonts
      AddOutputFilterByType DEFLATE application/javascript
      AddOutputFilterByType DEFLATE application/rss+xml
      AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
      AddOutputFilterByType DEFLATE application/x-font
      AddOutputFilterByType DEFLATE application/x-font-opentype
      AddOutputFilterByType DEFLATE application/x-font-otf
      AddOutputFilterByType DEFLATE application/x-font-truetype
      AddOutputFilterByType DEFLATE application/x-font-ttf
      AddOutputFilterByType DEFLATE application/x-javascript
      AddOutputFilterByType DEFLATE application/xhtml+xml
      AddOutputFilterByType DEFLATE application/xml
      AddOutputFilterByType DEFLATE font/opentype
      AddOutputFilterByType DEFLATE font/otf
      AddOutputFilterByType DEFLATE font/ttf
      AddOutputFilterByType DEFLATE image/svg+xml
      AddOutputFilterByType DEFLATE image/x-icon
      AddOutputFilterByType DEFLATE text/css
      AddOutputFilterByType DEFLATE text/html
      AddOutputFilterByType DEFLATE text/javascript
      AddOutputFilterByType DEFLATE text/plain
      AddOutputFilterByType DEFLATE text/xml
    
      # Remove browser bugs (only needed for really old browsers)
      BrowserMatch ^Mozilla/4 gzip-only-text/html
      BrowserMatch ^Mozilla/4\.0[678] no-gzip
      BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
      Header append Vary User-Agent
    </IfModule>

    Thanks again and enjoy your day!
    Vincent