I have updated my Wordpress site to include the most recent

I have updated my Wordpress site to include the most recent version of jquery (v 1.10.2) but anyone outside of this building is still seeing the old version (v 1.7.1). Its preventing some of my plugins from being tested by third party vendors. Can you provide any guidance? The site is currently in a 'coming soon' mode, but i can set up a link to send that will allow you to see the full site.