Smush Pro won't smush my images

Hello,

I have used the smush feature on the site but for some reason it still says i have 44 images that need recompressing. So i click bulk smush now and after it is done it still says 44 images need recompressing. I have tried clicking the update settings button at the bottom to see if that refreshes it but that never finished loading.

Any ideas?

  • Predrag Dubajic
    • Support

    Hey Marc,

    Hope you're doing well today :slight_smile:

    Thanks for granting access, I had a look at smushing panel and when I start the process there's a 500 internal server error showing in console.

    Unfortunately it doesn't tell us much on its own so we would need to check if there's any more info when debug is enabled.

    Can you enable debug log in your wp-config.php by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Start bulk smush process again and this should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    Best regards,
    Predrag

  • Marc
    • Site Builder, Child of Zeus

    Hi there, if I grant FTP access to you can you take care of the above to generate the report you need and look into the issues?

    Let me know how to provide this information in a safe environment. Regards, Marc

  • Adam Czajczyk
    • Support Gorilla

    Hello Marc!

    Hi there, if I grant FTP access to you can you take care of the above to generate the report you need and look into the issues?

    Yes, we can do that for you. Please make sure thou that you took a full backup of the site first and then send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here http://premium.wpmudev.org/contact/

    Select "I have a different question" from the drop-down list. 

    Please be sure to make a full backup of your entire site first!

    Best regards,
    Adam

  • Predrag Dubajic
    • Support

    Hi Marc,

    It turned out we had some issues with our email servers yesterday and that's why I was unable to see your message.
    I've received it now and did some tests on your site with debug enabled and there was fatal error showing in there:
    PHP Fatal error: Call to undefined function mime_content_type() in /wp-content/plugins/wp-smush-pro/lib/class-wp-smush-png_jpg.php on line 258

    I was unable to replicate this issue on my end but I've forwarded it to plugin developer to see if he can give me some more info about what could be causing it.

    In the meantime could you try performing plugin conflict test by disabling your other plugins so we can see if anything from there could be causing this?

    Best regards,
    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hello Marc!

    This error is very specific and uncommon. Could you please check what version of PHP are you using?

    The "mime_content_type()" function is a native PHP function and for some time it's been marked as deprecated and about to be removed from PHP. After all, it's been "de-deprecated" and is now fully available in PHP 7 natively. Before PHP 5.3.0 it was only available as PECL extension so if you server runs that old PHP it may not be installed at all.

    If you run anything "in between" 5.3.0 and current release PHP may be compiled with no support for "magic.mime" or it may just be disabled in PHP ini file.

    The bottom line is: if your server is running PHP up to 5.3.0 an update to never version would be a solution. If it already is never than this I would suggest switching to 7.x but if that's not a case please get in touch with your host and ask them about that aspect of PHP configuration on the PHP on your server. I think they should be able to help you get it enabled.

    Best regards,
    Adam

  • Marc
    • Site Builder, Child of Zeus

    Ok, so the hosts have done this and still nothing. What is happening is when we check the images we are told there are 410, when we try and smush we get to 291 and it says complete. Then I recjeck and it says there are 410 and there are more to be done, and repeat.... So what is next to try? Regards,

    Marc

  • Marc
    • Site Builder, Child of Zeus

    I don't think this is the problem, because we successfully use this plugin on other websites that are on the same shared hosting account as this one, is it possible this could be something else going on?

    Marc

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.