I hope all is well. I need your help please. I just install

Hello,
I hope all is well.
I need your help please.
I just install and activated W3 Total Cache on my WP multisite and immediately after activating it I lost access to my site completely. i can't access the front end nor the back end of the site.

I am trying not to freak-out.

the most recent backup is 45 days old and it is not a complete backup.
I went ahead and created a complete site backup for the site after the problem hoping you can help me with this problem.

Any thoughts?

thanks,
George

  • Vinod Dalvi
    • WP Unicorn

    Hi George,

    Sorry to hear of the problem you are having.

    You can just try deactivating W3 Total Cache plugin by renaming the plugin folder in the wp-content/plugins directory.

    Find more information about how to uninstall this plugin on the following page.

    http://www.shoutmeloud.com/how-to-delete-uninstall-w3-total-cache-wordpress-plugin.html

    The 500—Internal Server Error occurs when the Web server (running the Web Site) encountered an unexpected condition that prevented it from fulfilling the request by the client for access to the requested URL.

    Could you please check whether the answers provided on the following pages help you to fix this issue or not?

    http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-internal-server-error-in-wordpress/
    http://pcsupport.about.com/od/findbyerrormessage/a/500servererror.htm

    Best Regards,
    Vinod Dalvi

  • George
    • Design Lord, Child of Thor

    Hello Vinod Dalvi,
    Thank you for yourr direction on how to fix the error cased by W3 Total Cache plugin.
    I was able to gain access to the WP site however I could not fix the .htaccess file. Can you help please. I am attaching some pictures to give you an idea what i did and where I got stuck.

    I can see the initial (Hello world) post on the home page but when i click on the link, i get an 404 error message. Plz see attachments.

    Thanks again for your time.
    George

  • George
    • Design Lord, Child of Thor

    this is a cope of .htaccess file.
    I could not fix it. please help.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]# BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
    <IfModule mod_headers.c>
    Header append Vary User-Agent env=!dont-vary
    </IfModule>
    AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
    <IfModule mod_mime.c>
    # DEFLATE by extension
    AddOutputFilter DEFLATE js css htm html xml
    </IfModule>
    </IfModule>
    # END W3TC Browser Cache

  • George
    • Design Lord, Child of Thor

    // ** this is wp-config.php file
    I was not sure if you need it or not...** //

    <?php

    /**
    * The base configurations of the WordPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information
    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    *
    * This file is used by the wp-config.php creation script during the
    * installation. You don't have to use the web site, you can just copy this file
    * to "wp-config.php" and fill in the values.
    *
    * @package WordPress
    */

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'mathrthr_wo2001');

    /** MySQL database username */
    define('DB_USER', 'mathrthr_wo2001');

    /** MySQL database password */
    define('DB_PASSWORD', 'lPcELtaSylQX');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define('AUTH_KEY', '};^C/Z+ctBUOWisur+|pxRKY}@VrC/c!MZK&X}]uGV{ZK=E{sV;JftYe$k[a+_EKp]]ThmURcVRdWGUNCQ=gEo//d*N=m|=z_q[c(IW{SVK}aW@qZ[VViCN!Q+PnZKjk');
    define('SECURE_AUTH_KEY', 'hkncw;jEZ?QVm/XSFS&!{ngSXuVJ{T|MBtd/tS[)zjOsCUmJ$E=/gE!?@zoiStHZ$)[*}%BC^P)(D@*@j%reUW@(/MXQG)mwEjfedcv)}Gq}ugou@/rns$yN|*zu@Yv<');
    define('LOGGED_IN_KEY', '=lKlg%)]kC=Wp=+LNU^UFZ|Qnz&{QQGx]|%Qw$}xN]DHLArtLsHWyiF<saR}MTV@N+K_]%DbYYe_-/s(xBRO]v<xZ<zKj*]m/qsbhElBHn*CGLV&&<kNHbZjeC[$UYHb');
    define('NONCE_KEY', 'IB}&kh+?xARDYlDXlFO@SGkrUXVf&mAb<}gJ+)X-[;@NiyEm+s]Sv-mD>OJhXAEoogGiUjRX&gIJ!U;WXm]wicI@ZuEav?%nUFpQ=?t^SAzKg%UBdwYm&$zQKTm*v{Gu');
    define('AUTH_SALT', 's[;DSd&>UqtWXTGE?-nkls}AMfI_A_hLHfAIs%rB*LTQVySNkcwl-jFUZwWg^RTDxxRRh=c}uB&JM@MjJwVWVCkSUJXav)zAexE$vx_RaeM@-Mb+RriX{EZjzRaH-k;m');
    define('SECURE_AUTH_SALT', 'Wfhl+-w{LY@s_*LRjr<>=__R!z<{LlmdjR+ptLf@/nSVAUknN]Je%I}srxXRjqqL)HxXO>X>zmKL=(mX$h<UxhP(@L^Tmis?MtkFjhcfKgg|GeEKXY{xF%Rb=[TWF;nH');
    define('LOGGED_IN_SALT', 'GbdA|WN@xel@a|TK@Jq^=!Ma&W@cQP($_&UDf]yVZO|_xD}P$wqCO]WQOSkL%&m@!%J/LbsDB?CfAqMDTDHHe|pLb$Ze{F-YG-qU){eyEe/Uq/{UVUn$(;nlOspp|pjG');
    define('NONCE_SALT', 'E[HJFBi>Mlo*w$^Y*>>PeWs>UgowDF{EPJo>Wk=JqDC<HvI{!x%ype]X-hG[?Tt!AAy*j]$$QagmUuPODwcxYBy})FM{{F_^X;ZPs/g&(|b<aVeSL*B%mN!VEeRuLs%k');

    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_xsoh_';

    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'www.ma33a.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    define( 'SUNRISE', 'on' );

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    /**
    * Include tweaks requested by hosting providers. You can safely
    * remove either the file or comment out the lines below to get
    * to a vanilla state.
    */
    if (file_exists(ABSPATH . 'hosting_provider_filters.php')) {
    include('hosting_provider_filters.php');
    }

  • Patrick
    • Support Monkey

    Hi there @George

    I hope you're having a great day!

    I see that you have removed define( 'WP_CACHE', 'true' ); from your wp-config.php. That's good. :slight_smile:

    But I also see that you have added define( 'SUNRISE', 'on' ); in the wrong place in wp-config.php. Please move that line to just above the line that says /* That's all, stop editing! Happy blogging. */

    Also, you have not removed the W3 Total Cache code added to your htacess file. You must remove it. Your htaccess should contain only this:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Finally, please be sure that you have deleted the files mentioned in those instructions:

    advanced-cache.php
    db.php
    wp-total-cache-config.php

    ...and delete the w3tc folder from wp-content

  • George
    • Design Lord, Child of Thor

    Hello Patrick,
    I hope you are having a wonderful day.
    I want to thank you first for your help.
    Your directions fixed the problem and I have access to the post and pages.

    Can you advise me on how to prevent this problem from happening again.
    What is the best way to completely backup the system? Is there a trusted plugin you recommend? I do not want to worry about breaking the website every time I install a plugin.

    Is there a trusted way to speed the system?

    Is there a way to find out what plugin is slowing down the system?

    Thank again for all your help.
    George

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.