i hope somebody can

Hi, i hope somebody can help me :slight_smile: I have a multisite with the domain http://www.domain.de as main domain. now i wanna activate ssl via lets encrypt. After activating ssl on the domain https://www.domain.de i can not relogin to my site. the site is always reloading. What do i have to do when i wanna activate ssl in details and what do i have to change. Thnak you so much for help!

  • Jude

    Hey hannes

    Hope all is well with you !

    I have a multisite with the domain http://www.domain.de as main domain. now i wanna activate ssl via lets encrypt. After activating ssl on the domain https://www.domain.de i can not relogin to my site. the site is always reloading.

    Can you open your wp-config.php file and add the following lines there after replacing example.com with your own url

    define( 'WP_HOME' , 'https://example.com' );
    define( 'WP_SITEURL' , 'https://example.com' );

    Cheers
    Jude

  • hannes

    seems to be too easy :slight_smile: this will not work i get an reload of the login site with no error message, have a look at my wp-conig:

    efine('WP_DEBUG', false);

    define( 'WP_ALLOW_MULTISITE', true );

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.domain.de');
    define('WP_HOME','http://www.domain.de');
    define('WP_SITEURL','http://www.domain.de');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    define('SUNRISE', 'on');
    define('WP_MEMORY_LIMIT', '3000M');
    define( 'WP_HOME' , 'https://www.peptech.de' );
    define( 'WP_SITEURL' , 'https://www.peptech.de' );

    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    /* That's all, stop editing! Happy blogging. */

    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Definiert WordPress-Variablen und fügt Dateien ein. */
    require_once(ABSPATH . 'wp-settings.php');

    here is my htaccess:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    # END WordPress

    # BEGIN WP-HUMMINGBIRD-CACHING

    # END WP-HUMMINGBIRD-CACHING
    ## WP Defender - Prevent information disclosure ##
    <FilesMatch "\.(txt|md|exe|sh|bak|inc|pot|po|mo|log|sql)$">
    Order allow,deny
    Deny from all
    </FilesMatch>
    ## WP Defender - End ##
    <Files xmlrpc.php>
    Order deny,allow
    Deny from all
    </Files>
    # Deny access to important files
    <FilesMatch "(\.htaccess|\.htpasswd)">
    Require all denied
    </FilesMatch>

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.