i install the plugins and it kept giving me message like

i install the plugins and it kept giving me message like this: "Notice: WP_User->id was called with an argument that is deprecated since version 2.1! Use WP_User->ID instead. in /home3/jlaroque/public_html/wp-includes/functions.php on line 3495" i kept getting alot of this all over the website. any suggestion?