I installed Marketpress, but I can't see where to add products. I have WooCommerce installed and wonder if that has messed up MarketPress. Do you have a list of what pages are created when the plugin is installed? If WooCommerce has created problems, what steps do you recommend to be able to get MarketPress working? I don't see any list of shortcodes for MarketPress anywhere or any information other than the plugin page that doesn't offer any help with the capabilities that are listed.

  • Dimitris
    • Support Star

    Hey there Scott,

    hope you're doing good and thanks for reaching us! :slight_smile:

    This should be due to WooCommerce active instance. Have you tried to deactivate Woo and test if this resolve this?

    Is there a specific reason to use two e-commerce plugins? This will most probably cause more issues down the road, so I'd rather advise to stick only with one of them.

    Another solution, that will get both of those to work, would be to change the product post type of MarketPress plugin from "product" (which is the custom post type WooCommerce also uses) to "mp_product". :wink:
    This can be done via Store Settings -> General -> Advanced settings

    Warm regards,

  • Scooter
    • Flash Drive

    No reason to use 2 ecommerce plugins. I deactivated Woo and that helped as you suggested.

    The add to cart buttons are a white background with a black border, and do not display the 'Add to Cart" until you hover the mouse over the button, then it changes to a black button with white text. Where can that be changed?

    Also, when I click on the product image or product name it gives a 404 error "The page you were looking for was not found" /store/products/productname

  • Dimitris
    • Support Star

    Hello there Scott

    The add to cart buttons are a white background with a black border, and do not display the 'Add to Cart" until you hover the mouse over the button, then it changes to a black button with white text. Where can that be changed?

    It seems that there's a CSS rule with an "!important" suffix causing this.

    I just went ahead and inserted the following CSS rule to ProStyler Evo -> General settings -> Custom CSS Code in order to surpass this.

    /* WPMUDEV support - start */
    a.mp_button, .mp_orders_invoice a.button, button.mp_button {
      color: #333 !important;
    /* WPMUDEV support - end */

    Warm regards,

  • Scooter
    • Flash Drive

    The button fix using CSS helped, but now when hovering over the button it turns to a black background with black text.

    I switched the product post type to mp_product and now the products display in their page. However, instead of using the Blank Page template it looks like the page is using the Default Page template for some reason. The Default page template shows the posts, author and some strange changes to the menu which I don't want on the product page. It should be the Blank Page template.

  • Adam Czajczyk
    • Support Gorilla

    Hello Scooter!

    There are two "types" of pages in MarketPress. One "type" are "Store Pages" that are set in "Store pages" section of "Store Settings -> Presentation" page. These pages are:

    - Store Base
    - Product List
    - Shopping Cart
    - Checkout
    - Order Status

    They are "real pages" and you can edit them using regular WP Editor (as long as you keep shortcodes that were added to content by the plugin). Therefore, while editing them you can assign any available page templates to them.

    The other "type" of pages are "custom post type" pages and these are the "single product" pages. They are automatically generated based upon your products (custom post type of "mp_product" in this case) and WordPress is loading the default page template in that case. That may also depend on theme and look/behave differently on different sites (depending on what theme is active and how it works).

    To set a template of choice for these pages you may try to set the default template for single blog post in your theme settings (I noticed that there's none specified currently) and this would help in most cases. Again though - that may behave differently with different themes. Also, such setting will affect your regular blog posts too.

    A more "reliable" way then would be to create a custom page template. Here's more information on custom page templates:

    Such a page template file should be named following WordPress Template Hierarchy convention. A regular "single post" template file is named "single.php" and in case of custom post types you just add custom post type name to file name. In that case a custom page template file name would be: "single-mp_product.php".

    More on WP template hierarchy here:

    I'm not sure about the structure of your current theme unfortunately but usually an approach that works is:

    - make a copy of the page template file that you would like to assign to single product page
    - rename it to "single-mp_product.php"
    - edit file to adjust "template header" (as explained in the article on custom page templates that I linked to earlier in this post).

    If you have additional questions, let me know please.

    Best regards,

  • Scooter
    • Flash Drive

    Thanks for the information. It's a lot for me to digest since I'm not familiar with WordPress.
    But, I'll try to find out what to do by reading the blogs you provided on the subject.
    It sounds like I would find the existing template .php file I want to use and then copy it and rename it with the 'single-mp_product.php' name and then modify it and adjust the "template header"
    I'll see what I can do.

    Thanks for the help.

  • Predrag Dubajic
    • Support

    Hi Scooter,

    Apologies for the delay, there was no response in this thread so I was unaware that the support access was granted on your site.

    I had a look at your site and first thing missing was Shop page selected in Woocommerce Settings under Display tab.

    I did this for you however it was going to 403 forbidden page, this could either be blocked by one of your plugins or perhaps if have some additional rules in your .htaccess file.

    Creating new page (new-shop) didn't return the same error but the products were not shown on there.
    That issue seems to be related to your theme since when using default WP theme it works fine, it would be best checking this with the theme developers and see if theme is compatible with Woocommerce.

    Best regards,

  • Scooter
    • Flash Drive

    Thanks for taking a look at WooCommerce for me.
    I've contacted the Developer about this several times, and have not received a fix for this problem. The theme is compatible with WooCommerce, but I've never been able to get it to work.

    That's why I wanted to try MarketPress. But, using my theme, I ran into the problem with the single product display, and I'm not technically able to create the page that's needed (it's referenced earlier in this thread). So, I'm stuck without a solution.

    If you have any suggestions, I would be grateful.

  • Scooter
    • Flash Drive

    Hi there,
    I'm not sure how you did it......
    The page 'new-shop' shows it is using the default template, but it is not using that template obviously.
    But, I'm not complaining, I just don't understand that.....

    Anyway, if I rename the page to something like 'Store' or something like that, and then change the WooCommerce display page setting, will it still work?

    I'm very excited about this finally.

  • Dimitris
    • Support Star

    Hey there Scooter,

    hope you're doing good today!

    if I rename the page to something like 'Store' or something like that, and then change the WooCommerce display page setting, will it still work?

    If you edit the page's title and slug (URL), you don't even have to re-set that page as the main WooCommerce shop page as this happens auto-magically. :wink:

    Take care,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.