I installed CoursePress on a fresh WP install with only Akis. and Jetp. installed and it broke.

As soon as I activated the MarketPress plugin from within the CoursPress dash, I received this error message and the site became inaccessible.
"Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home2/holmes1e/public_html/wptest/wp-content/plugins/marketpress/includes/common/class-mp-product.php on line 339"
Why should this happen?
As soon as I went to my Host dash and renamed the marketpress plugin, the website was and is available again. I have basic WP 2015 theme and nothing else.

If Microsoft sold Office like this, they'd be out of business. This never got out of the starting gate. While I love all the features of this plugin, I just don't see how it's worth it. I have bee fixing my main site now for 9 months. I don't know how you can call this anything but a beta install.

Please explain this too me. How could I sell this to a client, or even expect to teach courses on an unstable platform like this. It is still in Beta.

  • jtstarke

    So, I updated the MarketPress3.002 plugin that was packed with the Coursepress to the 3.005 plugin suggested in the Dash and I get this error message and the site is again unavailable.
    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home2/holmes1e/public_html/wptest/wp-content/plugins/marketpress/includes/common/class-mp-product.php on line 369

    and it's the same error code, just moved, so I deactivated it again.

  • Sajid

    Hi @jtstarke

    Hope you are doing good today, beside these issues :slight_smile:

    First of all to make sure its not a bug. I tested it on my own install with same version of CoursePress and MarketPress. I activated MarketPress from coursepress and it activated without any issues (see screenshot).

    We test our plugins completely before releasing the plugins and their updates. But there can be issues with some hosting and site setup.

    To fix this issue :

    1. First of all make sure there are no conflicts with any of your plugin or theme. By running a quick plugin conflict test.
    2. Delete the both plugins.
    3. Install fresh copy of CoursePress.
    4. Now from CoursePress Pro > Settings > MarketPress install and activate the plugin.

    Let me know if that still does not work so one of our developer will take a closer look on your site.

    Thanks for your patience and understanding.

    Kind Regards
    Sajid J

  • jtstarke

    I'm still waiting for your developers to do something about my live and supposedly active site http://www.spirit-edu.com/learn that doesn't work and that you moved upstairs or wherever to your developers, and it's still not fixed. Students can sign up and pay but they are registered to a course there.
    Someone tried to sign up there this morning and got: the registration failed due to:
    10736 - A match of the Shipping Address City, State, and Postal Code failed.
    I did enter the correct shipping information.

  • Jose

    Hey James,

    I answered about the issues with spirit-edu site in the other thread.
    Let's keep it separate so that we can follow up better.

    The cryptic message

    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM
    means that there is an unexpected double colon.
    Most of the times, when there is a syntax issue, the line number pointed in the error is not the one causing problems.
    Any broken line in the code can lead to this kind of message.
    Since I'm not able to reproduce the problem in my install, I believe that this can be some corrupted file.

    Could you please send me the FTP and WP admin credentials via email as you did for the other domain?
    I'll take a closer look and keep you posted.

    Cheers,
    José

  • jtstarke

    No need to carry this any further Sajid, I just wanted to show that there are issues with the plugin that a real world install on a commercial server not custom made in the perfect world of your "test install" that someone less than coding adept will run into. It's similar to the problems I have had all along and it's obviously not unique to me or the hosting company I work with.
    The point is, without php coding experience and a constant desire to work on the php in the backend this is not a user friendly plugin as it stands. If you just want to teach and not code, there are more user friendly and stable plugins or platforms.

  • Jose

    Hi James,

    Totally clear about what you said.

    This is definitively a problem that we don't expect to happen and we willl try to sort it out.

    As I mentioned in the other thread, we just released version 1.2.6.5 cotaingin a good amount of fixes.

    Nevertheless, this specific issues looks like a problem during the install process. Maybe related to corrupted file or permission issues.

    I just wanted to show that there are issues with the plugin that a real world install on a commercial server not custom made in the perfect world of your "test install" that someone less than coding adept will run into

    In our dev environment we use a stack that emulates most popular hosting's setup. But there are always differences, specially related to resources ownership and permissions in shared hostings.

    If you are still open to give it a go, please try the latest version and let me kknw if the issues persists. In that case, I can jump into your site and try to debug directly there.

    Thanks,
    José

  • jtstarke

    Thanks Jose. I'll give it a try when I have the time. I know you want it to work. Unfortunately as a busy end user, I do feel frustrated when things don't work out of the box. This happens to be a shared hosting account for this install, where my main install is a VPS account.
    Thank you for your help on this. You can close this out if you want. I will test this when I have the time and let you know through a support email to your attention if it was resolved.

  • Hoang Ngo

    Hi, @jtstarke,
    I hope you are well today.

    Can you please check the PHP version of your shared host? This can be because late static binding, which is a feature of PHP 5.3, so if your host still using PHP 5.2, this can cause the issue.

    If possible, please check with your Host Provider to see if they can do the upgrade. PHP 5.2 is very old (around 9 years old, and deprecated). An upgrade to a newer version is something strongly recommend.

    Best regards,
    Hoang

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.