I installed courses pro and the media library wont show

Hi,
I installed courses pro and the media library wont show the images AND all the images off my site posts are gone.

I checked the folder and the images are the however, they wont show.

Please help ASAP... the is very urgent.

Thanks

  • Tyler Postle
    • CGO

    Hey Mark,

    Hope you're doing well today and thanks for your question!

    I have been testing this out on my own install(both single and multisite) and my images aren't disappearing. If you deactivate CoursePress do they come back? Just wanting to narrow down the cause here :slight_smile:

    Also, I notice you granted support access; however, the token appears to be invalid - do you mind re-voking then re-granting it?

    Is there any particular moment that the images stopped appearing? Right on activation or during setup or after? Any further information will help us reach a solution here.

    Look forward to hearing back Mark :slight_smile:

    Cheers,
    Tyler

  • Mark
    • New Recruit

    Thanks for the response Tyler!

    However, let me present the scenario... I got up this morning, checked my site updated 1 article everything was awesome. Noticed your new plugin CoursePress and thought it was worth a look and I could use. I did and BOOM images in the media gallery and site were gone however, still in the directory.. strange!

    I then deactivated, still no good... deleted, still no good so reluctantly restored a backup and was working again!!

    It's one of 2 plugins installed and both were yours. PopUp Pro... working fine but to me CoursePress seem to be a problem

    Any ideas as I don't want to install it again and go through that lol

  • Tyler Postle
    • CGO

    Hey Mark,

    Thanks for your timely reply :slight_smile:

    There is a known bug between Popup and CoursePress right now that has already been passed on to the developer and is being worked on; however, I don't believe it should cause something like this. The current known bug can cause PHP warnings/errors inside the PopUps.

    You tried deactivating all your plugins then activating just those two and it still happened? I'm still unable to reproduce it on my end. Are you seeing any PHP warnings/errors or Js errors in the console? Sorry for all the questions here, just wanting to see if I can reproduce this :slight_smile:

    Have a great rest of your day!

    All the best,
    Tyler

  • Marko Miljus
    • The Incredible Code Injector

    Hi guys,

    I've made further tests and found that first version of CP actually deleted media files if those were set in the elements and after deleted elements of units.

    The issue was fixed as from 1.0.1 version.

    I'll mark this one as resolved.

    Cheers,
    Marko

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.