I just activated upfront theme and try to edit. the site went a blank with "error" message

my website went to a complete blank with only “error” message.

I cannot access any of my site(s) including admin. I checked the error log from my FTP. It shows the log below.

Can you help me recover the site?

[01-Apr-2015 02:23:04 UTC] PHP Warning: Invalid argument supplied for foreach() in /home1/atlasoc1/public_html/lightcanvas.net/lc-website/plugins/pro-sites/pro-sites-files/modules/premium-themes.php on line 183

[01-Apr-2015 02:23:06 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/atlasoc1/public_html/lightcanvas.net/lc-website/plugins/pro-sites/pro-sites-files/modules/premium-themes.php:183) in /home1/atlasoc1/public_html/lightcanvas.net/wp-includes/option.php on line 748

[01-Apr-2015 02:23:06 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/atlasoc1/public_html/lightcanvas.net/lc-website/plugins/pro-sites/pro-sites-files/modules/premium-themes.php:183) in /home1/atlasoc1/public_html/lightcanvas.net/wp-includes/option.php on line 749

  • Vinod Dalvi
    • WP Unicorn

    Hi Yosuke,

    Sorry to hear of the problem you are having.

    I am using all the latest version of upfront themes on my test site without any issue.

    The messages that you shared are simple PHP warnings and most of the time it doesn’t affect functionality of site so it is nothing to worry about!

    To recover from this issue we have to change the theme on your site so just do it as following.

    Rename upfront theme directory to ThemeA (the broken one)

    Then rename any WordPress default theme directory like twentyfifteen to upfront theme directory that you changed above

    You will find all the themes on the following path in your WordPress install directory.

    wp-content/themes

    If you can’t do this yourself then would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just send log in info through our secured contact form: https://premium.wpmudev.org/contact/

    – Choose “I have a different question”

    – Include my name in the subject “Vinod Dalvi”

    – Include the URL of this post in your message so that I may track this issue better

    – Include login information (WordPress admin info username + password )

    – Include FTP Details

    I can see your site http://lightcanvas.net/ is working fine so are you having this issue on any other site?

    Kind Regards,

    Vinod Dalvi

  • Yosuke
    • Design Lord, Child of Thor

    Hi, @vinod Dalvi

    It seems to be fixed itself…. weird.

    (I just deleted the theme file completely from the server. but didn’t fix the problem right away, and I let it sit for the night. in the morning, it was working fine…. )

    But I reproduced the same problem again.

    When I re-install scribe and upfront. and went to editing mode. And clicked “upfront” menu on the menu bar(link = http://test.lightcanvas.net/service#), a little genetic pop up showed something like “please wait a little more” and when I clicked anywhere else on the site. The site went to the blank with error again(right now).

    Is this triggering some kind of server error? What do you think?

    this is happening on my Prosite.

  • Vinod Dalvi
    • WP Unicorn

    Hi Yosuke,

    Thank you for your reply.

    Can you check the JavaScript console for errors?

    In Chrome go to “View -> Developer -> JavaScript Console” and in Firefox you can go to “Tools -> Web Developer -> Console”

    Find information about how to open JavaScript browser console :

    http://webmasters.stackexchange.com/questions/8525/how-to-open-the-javascript-console-in-different-browsers

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    Let me know what JavaScript errors if any you are getting when you clicked “upfront” menu.

    Also would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking “Grant Access” button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Regards,

    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.