Autoblog not pulling all authors…

I just installed Autoblog, and it does most of what I need at the moment. The one big issue is that it isn’t pulling the author from some posts, while it is able to pull the author from others.

My problem sounds similar to the one posted in this discussion:

My implementation is different from his, however, so I thought it best to start a new discussion.

I run a Multi Site network and have not network activated the Autoblog plugin. We use it to allow individual blog admins to pull content from other blogs – mostly on our own network (we are a University, and usually deal with student blogs being pulled into the Instructor’s blog as an aggregator).

We also use an LDAP plugin for authentication. In my testing, ALL of the users of the source blog are on our network (as the blog is a part of our network) and ALL have come in via the LDAP plugin.

I had thought that all of the posts would have the same result – either that all authors were properly pulled into the new posts, or that none of the authors could be pulled in and my own user account would be substituted.

Oddly, that is not the case. Of 10 posts from a feed, 7 were properly pulled in and 3 were not.

It is also important to note that NONE of these users are a member of the blog running Autoblog. They are all members of the network.

Any idea why this might happen?