I just ordered WHMCS Provisioning addon but it is not

Hello. I just ordered WHMCS Provisioning addon but it is not working properly. I already configured everything right but there is a configuration about "Product Administrator" wich is denying me to create a new site/blog without set the Wordpress's administration in that field and when i set my wordpress admin's username in there, it create the new site under my username and not under the new customer username. As i see, the addon is unable to create username, so it is using my existing network admin username to create the new site. I am posting bellow my chat with Patrick about that issue. I wish you can help me to fix this out please.

Brunoat 5:39 pm
Hello fellows

Patrick Cohen
Patrick Cohenat 5:39 pm
@Bruno Hey there!

Bruno
Brunoat 5:39 pm
i have a problem here. Dunno if one of you already got this problem :slight_frown:... with WHMCS Auto provisioning

Bruno
Brunoat 5:40 pm
hey @Patrick... Nice to meet you !!

Bruno
Brunoat 5:40 pm
i am new to this community ^^

Patrick Cohen
Patrick Cohenat 5:40 pm
Nice to meet you too! Welcome! What's the issue?

Bruno
Brunoat 5:41 pm
i think this addon had some early update because its a bit different from the version presented at the addon's tutorial

Bruno
Brunoat 5:42 pm
then it have an issue related to the "Product Administrator" option during the package/product setup

Patrick Cohen
Patrick Cohenat 5:42 pm
Which addon? The latest integrates WHMCS Provisioning with Pro Sites so you can assign a Pro Site level to each WHMCS product. Is that the one you mean?

Bruno
Brunoat 5:42 pm
not, that new stuff i understand

Bruno
Brunoat 5:43 pm
the issue is with Product Administrator field

Bruno
Brunoat 5:43 pm
the auto-creation thru WHMCS doesnt work if i try to create /accept a new order without fill that field ( Product Administrator) at the package setup

Bruno
Brunoat 5:44 pm
but if i set, it ask me to set an Wordpress network ADMIN username in that field. So i did and i set my username in there

Bruno
Brunoat 5:45 pm
then it create the new site under my network using my network admin username, different from the new order/account's username. you got?

Bruno
Brunoat 5:46 pm
i want to be able to creat a new site with a new username under it

Bruno
Brunoat 5:46 pm
and not to create a new site under my username, because that doesnt make sense

Bruno
Brunoat 5:47 pm
my new customer ordered a new package and will use my admin login to log into his blog? cant be... :slight_frown:

Patrick Cohen
Patrick Cohenat 5:48 pm
@Bruno Ah, yes. I do understand now. As far as I am aware, the plugin should create a new user based on the email address the user enters, if the user does not already exist. See the "Known Issues" section on the usage page here: https://premium.wpmudev.org/project/whmcs-multisite-provisioning/#usage

Patrick Cohen
Patrick Cohenat 5:50 pm
However, WHMCS Provisioning is not my strongest area of expertise. I think you would be much better served by creating a support topic in the forums for this issue: https://premium.wpmudev.org/forums/tags/whmcs-mu-provisioning#question

Bruno
Brunoat 5:50 pm
hmmm

Patrick Cohen
Patrick Cohenat 5:51 pm
Hmmm indeed :slight_smile:

Bruno
Brunoat 5:52 pm
hehehe

Bruno
Brunoat 5:52 pm
that 'hmm' was for my brain thinking hehehe

Patrick Cohen
Patrick Cohenat 5:52 pm
:slight_smile: I must admit I have not played with this plugin in quite some time.

Bruno
Brunoat 5:52 pm
hmm

Bruno
Brunoat 5:53 pm
i will try to put that all into the ticket to have some help

Patrick Cohen
Patrick Cohenat 5:53 pm
Indeed! :smiley:

Bruno
Brunoat 5:53 pm
may i copy/paste what i wrotte here?

Patrick Cohen
Patrick Cohenat 5:53 pm
Excellent! I wish I could help more right now. Of course you can copy it, you wrote it, it's yours. :wink:

Bruno
Brunoat 5:54 pm
i mean to past to the support.. sorry man... my head is burning with so many things to do haha