subdirectory to subdomain errors

I just switched from subdirectory to subdomain to use the multi-domains plugin, yet the new site that I created "madewithife.johnjust.com is not working. The dashboard returns an internal server error. I've searched around and it seems that I might have to move my wordpress installation to my root folder or point the new site to my wordpress install. I need some guidance please

  • Nastia
    • Support Rock Star

    Hello Morounfolu , I hope you are doing well today!

    It is very tricky and complex to change a Multisite installation from subfolder to subdomain when the WordPress site is not new and have a lot in the database.

    Please let me know what steps you took to change the site's structure?

    Have you created a wildcard subdomain? Please see how to configure it here.

    Do you have access to your main site? If you do, use Search & Replace plugin to replace the URL of your installation.

    Please advise,

    Cheers,
    Nastia

  • Morounfolu
    • Flash Drive

    I have edited the htaccess and wpconfig files. I also have a wildcard subdomain setup already. I have access to my main site. I can use search and replace to replace the url of my installation, but since my current network sites are working, but not the one I created after I switched to subdomain, how would I alter the url for new sites henceforth and keep the old sites the same? Also how do I determine where my installation is?

  • Sajid
    • DEV MAN’s Sidekick

    Hello Morounfolu,
    Hope you are doing good today :slight_smile:

    It is redirecting to a page as if its not pointed to a directory. Could you please share the link of one of your subsites that are working ?

    Also, please enable support staff access so I could take a closer look. To grant access go to WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Best Regards,
    Sajid

  • Nastia
    • Support Rock Star

    Hello Morounfolu , I trust you are doing well today!

    Thank you for granting support access to your site.

    I was able to access to your site madewithife.johnjust.com from the network with no issue. The load speed was a little bit slow, this might be the reason why you've received Time Out Error.

    I've checked your system info and the max_execution_time is set to 0. Would you please increase by adding the following to your .htaccess file:

    php_value max_execution_time 300

    This should increase the max execution time.

    I also created a test subsite on your site and was able to access it with no issue.

    Please let us know how it went.

    Kind regards,
    Nastia

  • Adam Czajczyk
    • Support Gorilla

    Hello Morounfolu!

    I checked your site and all the (sub)domains mentioned here and I'm a bit confused. Here's the thing:

    - the "bythecouch.com" is your Multisite install
    - the "johnjust.com" seems to be another multisite
    - the "johnjust.com" - seems you attempted to add it to the Multi-Domains plugin of "bythecouch.com"
    - you mentioned some mapping

    Taking that into account, could you please describe in details what is the current setup and what exactly do you wish to achieve? I'm asking that because I got a feeling that we are all missing the point here and I'd like to make solid sure that we are on the same site :slight_smile:

    Best regards,
    Adam

  • Morounfolu
    • Flash Drive

    It's working now, but the wildcard dns availability for johnjust still says unavailable. I mapped bythecouch.com/johnjust to johnjust.com. I was initially wondering if that was what caused the errors I was getting when I first wanted to setup a johnjust.com subsite. In the last 24 hours though, I did get a dedicated ip(after reading that might be the source of my error).

  • Sajid
    • DEV MAN’s Sidekick

    Hello Morounfolu,
    Hope you are doing good today :slight_smile:

    I can see that the site http://johnjust.com/ is working just fine now. Do you still need help with this ?

    Regarding the second question of adding php_value max_execution_time 300 error. Please make sure you adding this line at very bottom of the .htaccess file in its own line.

    If does not work then try alternate method mentioned here:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    If still no luck then you have to contact your host since some hosting does not allow changing of these values per site basis.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.