I need help getting a plugin to install correctly - getting an error

I am getting this error when I try to install Duplicate Post plugin - but it is not showing up in my installed plugins list.

Help?

Error Message
Installing the plugin…

Destination folder already exists. /var/www/vhosts/embroiderytradeshow.org/httpdocs/wp-content/plugins/duplicate-post/

Plugin install failed.

If I knew how to delete this in the destination folder, would that solve it?
If so, how do I do that?

thx much
Jennifer