I need to update php

I have been told by my domain host (1&1) that I'm being charged for having a website with php 5.5 or lower. I have no idea what this means and they won't help me. I've searched for how to update php and I don't know enough to follow the directions; I don't even know how to locate my version in WordPress. Can you help me get this done?