I need your help resolving login error related with domain mapping: "Warning: striplashes() ...

Hi everyone, I'm running the latest version of Wordpress multisite and amongst other uptodate plugins, domain mapping.

Unfortunately I am getting the following error when logging in to the administrator dashboard:

Warning: striplashes() expects parameter 1 to be string, object given in /var/sites/.../plugins/domain-mapping/classes/Vendor/CHttpRequest.php on line 155

Speed tests on Pindom are also widely varied, from 2.5 seconds to 11.5 seconds but in particularly I noticed there is a script loading (or not loading) relate to the domain mapping.
See line 2 here: http://tools.pingdom.com/fpt/#!/enFASO/Ccf.wales
(http://cwebs.org/dm-sso-endpoint/1448006497/?dm_action=domainmap-setup-cdsso)

I would be very grateful for any ideal that would resolve this.

  • Sajid

    Hi @Daniel

    Hope you are doing good today :slight_smile:

    I am sorry to hear things are not working as expected. It appears to be issue with Cross Domain Single Sign On.

    Try enabling "Load Cross-domain autologin asynchronously" from Network > Settings > Domain Mapping > Mapping Options > Cross-domain autologin. This will load the necessary scripts asynchronously and helpful to avoid render blocking on load.

    If the above don't fix then try to disable "Cross-domain autologin" option temporarily from Network > Settings > Domain Mapping > Mapping Options to see if that makes any difference.

    For warning issue, did you tried deactivating third party plugins to check for possible plugin conflict. If no, then run a quick plugin conflict test as illustrated in getting support manual.
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    I am also flagging developer on this issue for his invaluable feedback on this matter.

    Meanwhile you can hide the message by adding following define in wp-config.php file by replacing define('WP_DEBUG', true);

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    This will create debug.log file instead of displaying the error messages.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Sajid

    Hi @Daniel

    Hope you are doing good today :slight_smile:

    I am glad to know its better now and you found the culprit.

    When you are logged in on front or when you logged in as administrator in wp-admin ?

    I tried to login on your network using support staff access and it worked fine. Not loading like frontend but that is the common speed for admin section.

    The backend speed depends on number of factors, the daily updates check of plugin, themes and cores. Plugins individually making it slow because of waiting for outside calls, loading affiliate banners, waiting HTTP curl requests, making MySQL calls for data etc...

    I also created a test user on your website with subscriber role to be logged in on frontend. But that did make any difference on front after login with test user. It still loading with awesome 1.5 seconds speed.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.