I purchased this subscription for this theme, but every

I purchased this subscription for the upfront themes, but every time I install it or try to activate the theme I am redirected to a 500 Internal error message.

  • Vinod Dalvi
    • WP Unicorn

    Hi Jessica,

    Welcome to the WPMU Dev community and thanks for posting on the forum.

    I have tested it on my test site using latest version of Spirit theme and it worked fine without any issue.

    Is it happening for you only with this theme or with other themes also including default WordPress theme?

    This can be due to plugin conflict on your site.

    You can just try on your development site deactivating all other plugins as displayed in the following flowchart to know which plugin is conflicting if any.

    https://premium.wpmudev.org/manuals/getting-support/

    Would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,
    Vinod Dalvi

  • Jessica Canning
    • WPMU DEV Initiate

    Hi Vinod,

    When I went to allow access to the site through the WPMU dashboard the following error appeared

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, you@example.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

  • Vinod Dalvi
    • WP Unicorn

    Hi Jessica,

    Thank you for your reply.

    So it seems this issue is not specific to the theme.

    Have you checked the server error log for more information about the error?

    The 500—Internal Server Error occurs when the Web server (running the Web Site) encountered an unexpected condition that prevented it from fulfilling the request by the client for access to the requested URL.

    Could you please check whether the solution posted on the following pages help you to fix this issue?

    http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-internal-server-error-in-wordpress/
    http://pcsupport.about.com/od/findbyerrormessage/a/500servererror.htm

    Regards,
    Vinod Dalvi

  • Ash
    • WordPress Hacker

    Hello @Jessica

    I hope you are well today.

    Yes, I got the same issue when I installed theme in your site.

    Would you please post your htaccess message here?

    Also, would you please let me know if you have mod_security and mode_pagespeed installed in your server?

    Please let us know.

    Cheers
    Ash

  • Ash
    • WordPress Hacker

    Hello @Jessica Canning

    You will find your htaccess in your server. You need to use FTP or file manager option in cPanel and look at /public_html/ folder, where wp-admin, wp-content etc folders are. Download that file and open in an editor, and paste the code in here.

    mod_security and mode_pagespeed are server side modules. You need to ask your host to be sure.

    Please let us know.

    Cheers
    Ash

  • Jessica Canning
    • WPMU DEV Initiate

    File content is as follows:
    <<<<

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    >>>>

  • Ash
    • WordPress Hacker

    Hello @Jessica Canning

    I hope you are well today.

    The htaccess looks okay. Did you hear back anything from your server guys about mod_security and mode_pagespeed? And finally, let me know what is your highest memory limit. I will talk to a developer with these info.

    Cheers
    Ash

  • Jessica Canning
    • WPMU DEV Initiate

    We do not have mod_security or mode_pagespeed. The activation of the plugin kills the entire Wordpress Database Connection. It looks like an overload of some sorts.

    Your support has been great, but I don't think this is the plugin will be best for our website seeing it has this many issues and bugs from the start. Even if we did fix this issue I am afraid of other issues in the future and we can't sacrifice our business when it goes down. I will submit for a full refund.

    Thank you Ash for all your help

  • Zarrar
    • Design Lord, Child of Thor

    Hi Jessica,
    What kind of server configuration are you using. You should not be having so many problems. Are you on shared hosting, VPS, or dedicated? What OS, PHP version are you using. What kind of control panel is it, cPanel, Plesk or other. The issues you are having are not WordPress or plugin based, it is something on your hardware, operating system and server configuration. Using WP is a very straight forward process.

    NOTE: Based on your original 500 error, it is most likely a DNS issue as well. Are you using a subdomain, or alias?
    Best.
    Zarrar

  • Vinod Dalvi
    • WP Unicorn

    Hi Jessica,

    We can definitely resolve the issue for you as the theme is working fine our site so it seems like server or WordPress site specific issue.

    Would you mind if I access your site and did some testing? This might help get to the bottom of this faster. If this is ok, just send log in info through our secured contact form: https://premium.wpmudev.org/contact/
    - Choose "I have a different question"
    - Include my name in the subject "Vinod Dalvi"
    - Include the URL of this post in your message so that I may track this issue better
    - Include login information (Wordpress admin info username + password )
    - Include FTP Details

    Regards,
    Vinod Dalvi

  • Vinod Dalvi
    • WP Unicorn

    Hi Jessica,

    Thank you for sending the admin details.

    I tried to log in using sent admin credentials but it displayed the "Internal Server Error" message which i think due to the theme as you have reported it here so to troubleshoot this issue could you please also send the FTP details as requested in my previous reply?

    Regards,
    Vinod Dalvi

  • Jessica Canning
    • WPMU DEV Initiate

    I have allowed access to the site, but have not heard anything from support for 2 days. I need to start working on my website, but I can't if I don't have a theme. Can someone on staff help please. If this can't be resolved in the next week I will need to look for another theme as this project has already been delayed too long.

  • Vinod Dalvi
    • WP Unicorn

    Hi Jessica,

    Thank you for your patience here and thank you for sending the FTP details.

    I tried to access your site using sent FTP credentials but it displayed the "530 Access denied." error message as shown in the attached screenshot.

    Could you please make sure that the sent details are correct and send me the correct working credentials?

    Also please retest it and if you get Internal error message then please check the server error log to see whether it contains any additional information regarding this error.

    You can find the error log on the server as described on the following page.

    https://premium.wpmudev.org/blog/wordpress-troubleshooting-basics-how-to-check-your-error-logs/

    Regards,
    Vinod Dalvi

  • Vinod Dalvi
    • WP Unicorn

    Hi Jessica,

    I can see you have sent the same FTP details again which is not working for me.

    I tried using different Encryption method and protocol but it didn't work.

    I searched for this error message and found any FTP component or client software. If you get a "530 access denied" response from the USER command (i.e. when the FTP client is attempting to login) it is possible that the FTP server is rejecting the login attempt based on the client’s IP address so could you please make sure it's not the case?

    Also if you don't mind then instead of sending FTP details which is not working for me, please send the cPanel details of your site.

    Regards,
    Vinod Dalvi

  • Michael Bissett
    • Recruit

    Hey @Jessica Canning! :slight_smile:

    As it turns out, the issue looked to be memory related. Checking out your site via FTP, I noticed that you had these two entries inside of your wp-config.php:

    define('WP_MEMORY_LIMIT', '64M');
    ini_set("memory_limit","256M");

    After changing that to this (giving more memory for WordPress itself to work with, as it was only being allowed to use 64 MB):

    define('WP_MEMORY_LIMIT', '256M');

    The 500 Internal Server error ceased to show up on my end. Could you confirm the same on your end please? :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.