I ran Hummingbird

Hello,

I ran Hummingbird and it said to enable compression. I'm running Nginx and my file is in /etc/nginx/nginx.conf. I took copied what Hummingbird told me, but when I put it outside of the http { } block in that file, Nginx didn't like that, so I put it WITHIN the http { } block and was able to restart Nginx successfully...however, Hummingbird is still telling me that Javascript compression is not enabled. I'm not sure why. HTML and CSS say "Enabled".

    • Nazmul H. Rupok
      • The Incredible Code Injector

      Hi there,

      Hope you are doing well today. I have checked and I guess the code was not added properly on right place. You need to add the suggested code below to the http section in the nginx.conf file.

      Would you clarify what you are referring by "Nginx didn't like that"? Did you face any error? You can also contact your hosting provider to make these changes. I hope it will work fine after the code is being added. Make sure to click on "Re-Check Status" after that.

      Let us know how it goes and if we could assist further from our end.

      Have a nice day. Cheers!
      Nazmul

  • TJ
    • Flash Drive

    When I add the gzip settings immediately outside of the http { } block, this is what Nginx says:

    nginx: [emerg] "gzip" directive is not allowed here in /etc/nginx/nginx.conf:101
    nginx: configuration file /etc/nginx/nginx.conf test failed

    When I add the gzip settings back within the http { } block, this is what it says:
    nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
    nginx: configuration file /etc/nginx/nginx.conf test is successful

    I'm running: nginx version: nginx/1.10.0 (Ubuntu)

  • Nazmul H. Rupok
    • The Incredible Code Injector

    Hi TJ

    Hope you are doing well. Apologizing for the late follow up. Are you still facing this? Can you ask your hosting support to add the code for you. They should be able to put it on right place.

    If you provide me with additional login credentials, I can look into it more and try to add that as well.

    https://premium.wpmudev.org/contact/#i-have-a-different-question
    Please visit our private Contact page and complete the form with the following information:

    Subject: "Attn: Nazmul"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - WordPress Admin login:
    Admin username
    Admin password
    Login url

    - cPanel credentials (FTP won't help to edit the files)

    **If you keep support access active then no need to send in wp-admin"

    Best regards,
    Nazmul

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.