I recently purchased and installed Appointments+ in my

Hello, I recently purchased and installed Appointments+ in my Wordpress blog. I have been working on the settings for a few weeks, tested the booking calendar, emails, etc. and had no issues at all however, since a few days ago the calendar isn't working.
The available times and dates can be seen on the calendar but when you hover over, nothing happens.
I deleted the shortcodes and put them in again but no luck.

Can you let me know what the issue is please?
Customers can't book appointments and these are likely lost sales. I need your help please.

Thanks
Beatriz

  • Alexander

    Hi Beatriz,

    This is something I'd like to help workout with you, although I won't be able to at the moment because you've opted to cancel your membership, and are now considered inactive.

    You can reactivate your Appointments+ membership from here: https://premium.wpmudev.org/project/appointments-plus/

    Or you could checkout one of our new plans here: https://premium.wpmudev.org/plans/

    Or, if you'd like to get in touch with us regarding you account, you can use our contact form and choose "I have a billing question"
    https://premium.wpmudev.org/contact/

  • beatrizmudev

    Hi Alexander,

    I am starting to find communication with wpmudev confusing.

    In the first place, I recall questioning the monthly payment issue, I don't recall cancelling my membership.

    Secondly, you include a link to reactivate my account in your email however, straight after I have received your email I received another email thanking me for my payment...

    Can you confirm what my account status is and whether you can help me with my issue please?

    Thanks
    Beatriz

  • Alexander

    Hello @beatrizmudev,

    My apologies for the confusion here. Yesterday when your thread came through, your account was showing up as inactive. Yesterday was the renewal date, so it's possible there was a short lapse somehow. Regardless, your account is active now - feel free to direct any concerns to our billing department, as I'm unable to discuss it with you here.

    I'd love to help you get this issue sorted out.

    On the appointments+ page, can you check the javascript console for errors? In Chrome go to "View -> Developer -> Javascript Console" and in Firefox you can go to "Tools -> Web Developer -> Console"

    Also, can you try switching to the default theme. If it's working in the twentytwelve theme, we know there's a theme conflict, and we can see what needs to be done to correct it.

    And finally, would you mind letting me see the page where this issue is ocurring? I might be able to spot something right away that could help us resolve it faster.

    Best regards

  • Alexander

    @beatrizmudev,

    I'm so sorry for the confusion here! Yesterday your account showed up as inactive. This is usually the result of a user canceling their subscription. As it was your renewal date, it's possible that the payment was briefly delayed, or something caused a short gap. I'm very sorry this happened. As it stands, your account is most certainly active, and if you have any other concerns feel free to get in touch with our billing department as I'm unable to discuss it here. I'm sorry again for the confusion.

    As for the issue at hand, I'd love to help you get this figured out.

    Can you check the javascript console for errors? In Chrome go to "View -> Developer -> Javascript Console" and in Firefox you can go to "Tools -> Web Developer -> Console"

    Also, can you try switching to the default theme temporarily? See if that makes a difference. If it works in the default theme, we know there's a theme conflict, and we can start looking in that direction to get things fixed.

    And finally, would you mind letting me take a look at the page where this is happening? I might be able to spot anything out of the ordinary right away that would be useful to us.

    Best regards

  • beatrizmudev

    Hello Alexander,

    Thank you for your email.
    It all sounds very strange. I never cancelled my subscription, deactivated my account or refused to pay the fee. I don't wish to contact anybody about my payments. I just need the plug in to work like it has worked from the day I subscribed until the issue with payment/renewal happened.

    As far as I can see there are no errors with the javascript console. The plugin has worked well since the day I subscribed with the theme I am using, no theme conflict there. If you want to see the page, please go to http://www.beatrizvalverdegarzon.com and click on 'Coaching and SEI 1:1, Free Appointments' drop down menu where you will see the Appointments+ calendar is showing but you are unable to make a booking.

    I notice that my account is now in order and next payment will go out on 16 July. I really need this to work, I am getting more and more visitors to my site and I need the calendar to work properly.

    Please advice,

  • Alexander

    I noticed you have a fatal error in your footer:

    Fatal error: Cannot use object of type stdClass as array in /home2/beahg/public_html/wp-content/plugins/woodojo/bundled/woodojo-social-widgets/widgets/widget-woodojo-tweets.php on line 325

    Try disabling the "woodojo" plugin and see if things are any better.

    If not, can you start by deactivating all your other plugins? If Appointments+ starts working, then you can start activating them one by one and we can find out what's causing a conflict.

    Let me know what you find out.

    Best regards

  • Alexander

    @beatrizmudev,

    Not quite, it just means Woodojo is causing errors. With a fatal error like that, it's likely that it would cause issues with other plugins as well. I would advise making sure that plugin is up to date.

    It might actually be another plugin that's causing Woodojo to crash, which in turn breaks Appointments+

    You can test this by deactivating all other plugins than Woodojo and seeing if the error is still there.

    Best regards

  • beatrizmudev

    Hi Alex, I checked all plugins and it appeared that Woodojo wasn't updated but no message was displayed so had to uninstall and install the newest version. The calendar works now :slight_smile:

    I still have other issue with Apps+. I would like to use the [app_pagination] to add links to increase/decrease in months. I follow the instructions and I add ''1'' but the links show ''previous week'' and ''next week''. I have tried different numbers ''2'', ''4'', etc. but they only show 'week' not months.

    Can you help me with this tool please?

    Thanks

  • pxwm

    Hi @beatrizmudev

    Can you please loggin in to the Wordpress dashboard as Admin
    Then select Pages in the left hand menu
    Then select your appointment page - it should be called 'Make an Appointment' unless you have changed the page name.
    Then check the shortcodes

    If you want to display a monthly calendar scheduler then can you confirm if you have the following shortcodes:-

    [app_monthly_schedule][app_pagination month="1"]

    If they are different to this then can you replace with the above.
    Then click 'update' on the far right to save.
    Please make sure you replace and don't duplicate.

    This should then display a monthly calendar with 'Previous Month' and 'Next Month'

    If it doesn't could you post all the shortcodes you have in your 'appointment' page
    Regards
    SteveB

  • beatrizmudev

    Thanks Alex.

    @Steve - I am sorry but that solution doesn't work. These are the shortcodes I have

    [app_services][app_pagination month=''1''][app_monthly_schedule][app_confirmation]

    I have also tried
    [app_services][app_monthly_schedule][app_pagination month=''1''][app_confirmation]

    It makes no difference the order, both of these combinations still show ''previous week'' and ''next week''

    Let me know what else I can do.

  • Alexander

    @beatrizmudev,

    I just tried it and it worked for me. The only potential issue I see is if you copied and pasted directly from his post above, you'd have two single quotes instead of a double quote.

    So if you'd like to copy/paste, try this:
    [app_services][app_pagination month="1"][app_monthly_schedule][app_confirmation]

    You can use one set of single quotes as well, it doesn't really matter. Let us know if this works for you.

    Best regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.