I recently tried to install Multisite for wordpress. I got

I recently tried to install Multisite for wordpress. I got to the point where I had the Network solutions set and all I had to add was code to my public .htacess wp-content files but then when I tried to reload the page, I got an error message about my database. I was told to post the following into a wp forum...

wp_1_posts: Table 'marhud54_wrdp1.wp_1_posts' doesn't exist
wp_1_comments: Table 'marhud54_wrdp1.wp_1_comments' doesn't exist
wp_1_links: Table 'marhud54_wrdp1.wp_1_links' doesn't exist
wp_1_options: Table 'marhud54_wrdp1.wp_1_options' doesn't exist
wp_1_postmeta: Table 'marhud54_wrdp1.wp_1_postmeta' doesn't exist
wp_1_terms: Table 'marhud54_wrdp1.wp_1_terms' doesn't exist
wp_1_term_taxonomy: Table 'marhud54_wrdp1.wp_1_term_taxonomy' doesn't exist
wp_1_term_relationships: Table 'marhud54_wrdp1.wp_1_term_relationships' doesn't exist
wp_1_commentmeta: Table 'marhud54_wrdp1.wp_1_commentmeta' doesn't exist

  • Mike
    • New Recruit

    Hi @marhud54

    Thanks for posting!

    According to these errors, you don't have any of the Wordpress tables setup, did the Wordpress install ever run? If this is a new site I'd start again to make sure it's installed correctly and follow the installation guide here:
    http://codex.wordpress.org/Installing_WordPress

    Make sure you create the table and a user and grant the user access to the table then use that same user account with Wordpress.

    Hope this helps.

    Cheers,
    Mike

  • marhud54
    • Design Lord, Child of Thor

    Ok, I think I have it up and running. I just have one more question because I think this was the step that destroyed everything last time. In installing my multi site, it says to Add the following to your .htaccess file in /home/marhud54/public_html/, replacing other WordPress rules:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Am I really supposed to delte everything from my htacess file?

  • Mike
    • New Recruit

    Hi @marhud54

    What are the current contents of your .htaccess file?

    There should be a "Wordpress" section to it, normally you would just delete those but post it here if you aren't sure and I'll let you know what I think.

    Is wordpress working ok as a Multisite now?

    Cheers,
    Mike

  • marhud54
    • Design Lord, Child of Thor

    err...now it says my database is having problems and told me to post this code in a forum:
    wp_1_posts: Table 'marhud54_wrdp1.wp_1_posts' doesn't exist
    wp_1_comments: Table 'marhud54_wrdp1.wp_1_comments' doesn't exist
    wp_1_links: Table 'marhud54_wrdp1.wp_1_links' doesn't exist
    wp_1_options: Table 'marhud54_wrdp1.wp_1_options' doesn't exist
    wp_1_postmeta: Table 'marhud54_wrdp1.wp_1_postmeta' doesn't exist
    wp_1_terms: Table 'marhud54_wrdp1.wp_1_terms' doesn't exist
    wp_1_term_taxonomy: Table 'marhud54_wrdp1.wp_1_term_taxonomy' doesn't exist
    wp_1_term_relationships: Table 'marhud54_wrdp1.wp_1_term_relationships' doesn't exist
    wp_1_commentmeta: Table 'marhud54_wrdp1.wp_1_commentmeta' doesn't exist

    I completed the wp-config.php multisite configuration and thought everything was a go. I didn't do anything to my htaccess yet, but here is what I have on my htaccess page
    # BEGIN supercache
    <IfModule mod_mime.c>
    <FilesMatch "\.html\.gz$">
    ForceType text/html
    FileETag None
    </FilesMatch>
    AddEncoding gzip .gz
    AddType text/html .gz
    </IfModule>
    <IfModule mod_deflate.c>
    SetEnvIfNoCase Request_URI \.gz$ no-gzip
    </IfModule>
    <IfModule mod_headers.c>
    Header set Vary "Accept-Encoding, Cookie"
    Header set Cache-Control 'max-age=3, must-revalidate'
    </IfModule>
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType text/html A3
    </IfModule>

    # END supercache

  • Mike
    • New Recruit

    Hi @marhud54

    It looks like you have supercache running, that could be messing with things.

    Are you using a host with cPanel? Is there anything on there that you want to keep? I guess not since you have uninstalled it and reinstalled it a couple of times.

    If you send me your details I'll see if I can have a look and help out.

    To send the login details you can send them through our contact form
    - In the subject field add "Attn: Mike"
    - Link back to this thread
    - Include admin/network access
    - Include FTP & cPanel logins
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    If you are having problems with the contact form you can send them to contact(at)wpmudev.org please make sure the subject line is Attn: Mike and all details are included :slight_smile:

    Cheers,
    Mike

  • Mike
    • New Recruit

    Hi @marhud50

    I tried to login to your site and Wordpress says that the database is not correctly set up so you need to get that fixed before we can help.

    From your previous messages it sounded like a permissions problem or something, but I think it is more than that.

    I also see that you have started 4 other threads asking the same question and on all but one of them we are awaiting your reply:
    https://premium.wpmudev.org/forums/topic/installing-multisite-on-wordpress-with-a-mac
    https://premium.wpmudev.org/forums/topic/how-to-i-install-multisite-and-then-marketpress
    https://premium.wpmudev.org/forums/topic/difficulty-installing-multisite
    https://premium.wpmudev.org/forums/topic/how-to-i-add-code-to-my-public-file-what-is-a-public-file

    Please answer these posts or mark them as resolved because you shouldn't have 5 posts all asking the same thing.

    We cannot help you install Wordpress we can only help you once you have finished the install and everything is working. I suggest that you remove the database(s) and files and then start again and install if from scratch.

    If you cannot install it or do not know how, then I suggest that you either speak to your web host, hire someone to install it for you(you can use someone on WPMU Jobs if you like) or follow the instructions here: http://codex.wordpress.org/Installing_WordPress

    Wordpress is very easy to install and use, if you are struggling to do that, then I suggest you hire someone to complete the entire project for you rather than spend weeks trying to figure it out yourself.

    I am marking this thread as resolved and if you have a question after you have Wordpress working, then you can create ONE new thread and ask your question there.

    Cheers,
    Mike

  • marhud54
    • Design Lord, Child of Thor

    I ended up trying to start from scratch and basically accidentally deleted everything. I might be posting about this again in the future, but for now will mark it as resolved since I have no longer have anything to work with : )

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.