I see a warning to update the plugin to version 2.4.1 but

I see a warning to update the plugin to version 2.4.1 but when I action it, the update doesn't happen, the warning remains. I've tried it a few times now, to no avail. What can I do to update it?