I set up backup with google drive (Daily once).I followed

I set up backup with google drive (Daily once).I followed the instruction to set it up .
But when I click the Authorize button I see

''
401. That’s an error.

Error: invalid_client

The OAuth client was not found.
Request Details

That’s all we know.''

So I enabled the support access and put my Google info there ,I request to check the setting when possible

Thanks
Monsur

  • Nithin
    • Support Wizard

    Hi Monsur,

    Hope you are doing good today. :slight_smile:

    I checked your website, and was able to replicate this error. It's more from Googles side, could you please check and confirm that you have enabled Drive API, in your API Manager. If that didn't work please try renaming your project, and try to authorize it.

    Please let us know how that goes, so that we could give a closer look.

    Kind Regards,
    Nithin

  • Abu Monsur
    • The Incredible Code Injector

    Thank you
    Of course,I enabled Drive API
    I also tried renaming and also deleted the first and created new one ,no solution
    I still see
    ''401. That’s an error.

    Error: invalid_client

    The OAuth client was not found.
    Request Details

    That’s all we know.''

    As the I enabled the support access and gave my Google drive email and password there ,pls check yourself
    N.B.there is a similar thread-https://premium.wpmudev.org/forums/topic/snapshot-will-not-authorize-google-drive
    Thanks
    Monsur

  • Nithin
    • Support Wizard

    Hi monsur,

    Hope you are doing good today. :slight_smile:

    I'm not sure what is the exact problem in 'ctgdb' destination that you've created, I checked your Google drive credentials, and it looks correct, but somehow it's not being authorized. I created a new folder 'foo', a new project 'mypro' in your Google drive, and I was able to authorize it.

    In creating 'mypro', the instructions are pretty same with what you have done with 'ctgdb' destination, so it's hard to determine what is being missed with the 'ctgdb' project, it could be from the Googles side when it comes to authorization. Right now the 'foo' destination has been authorized, you can either continue with it, or creating a new project should also make it work. In case, if you need the credentials of 'mypro' project, I have saved those in the quick message section.

    I hope this helps. Please let us know if you still find any issues with it, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin
    • Support Wizard

    Hi monsur,

    Hope you are doing good today. :slight_smile:

    I believe you are looking for the automatic backup option, I cannot recall whether you have added a new Snapshot or not. If not, please add a new Snapshot, under Snapshot > Add New.

    Please select the desired settings, and destination as Google Drive. For Snapshot to make automatic backup, you'll have to select scheduled options listed. Selecting any of these options will start a backup within minutes, and then will repeat on the selected time period. Selecting 'run immediate' will take a backup only once.

    Please check this link for more info: https://premium.wpmudev.org/blog/backup-with-snapshot/

    If you have already followed these steps, and still have issues, please enable support access. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Abu Monsur
    • The Incredible Code Injector

    Thank you very much for the niche,this project was set up by the support.I want backup once in a day.I am not sure what was done by the support last time,I enabled access again,pls check what the problem is .I saw under setting
    PHP runtime information
    Display Errors 1

    Thanks
    Monsur

  • Nithin
    • Support Wizard

    Hi monsur,

    Hope you are doing good today. :slight_smile:

    I tried a small manual backup of your database, and it seems to send the files to Google Drive. I have made a new backup of you entire content with the interval to run daily once, please let us know how that goes.

    I did notice that you have max_execution_time set to 30, this could lead to issues if you have high volume of content to backup. If you find your backup as failed, would recommend that you increase your timeout limit to a greater value. If you are unsure about increasing those value, you could ask your host to make those changes.

    You can check this link on how to make those changes yourself: https://premium.wpmudev.org/blog/increase-memory-limit/

    Please let us know how it goes, have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.