I signed up

Hi Guys,

I signed up yesterday and part of my motivation for doing so was to see whether I could move from ManageWP to your Hub to manage my client's websites, where I offer automated backups, performance management, security management and uptime management.

Unfortunately, out of the three websites I have added to the Hub currently two (the one referenced on this ticket and ls25callsolutions.co.uk) are failing when backing up.

It is imperative that I have a reliable backup facility so I need to get this resolved if I am to stay with WPMU Dev (which I would like to as I see value in the other parts of your service).

I have granted you access to 16yorkplace.co.uk.

Thanks

Matt

  • Matthew

    Further to this, I notice that a backup is currently running (or so it says under Managed Backups) but when I check the log it says:

    [Cron][2017-03-10 01:05:19][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-03-10 02:05:17][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-03-10 03:05:25][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-03-10 04:05:32][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-03-10 05:05:19][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-03-10 06:05:30][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-03-10 07:05:19][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-03-10 08:05:26][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-03-10 09:05:14][Warning] Immediate hook misfired, kickstart backup processing
    [Cron][2017-03-10 10:05:12][Warning] Immediate hook misfired, kickstart backup processing

    Can you please advise on how I cancel this backup and also the root cause of it failing?

    Thanks

    Matt

  • Matthew

    Further to this again, I have now added another site to my Hub (concept-home.co.uk) and when I attempt to back this one, I get:

    "This request takes too long to process, it is timed out by the server. If it should not be timed out, please contact administrator of this web site to increase 'Connection Timeout'."

    As you can see, I am running into all kinds of issues with Snapshot.

    Currently only 1 of the 4 sites added had backed up successfully.

    Matt

  • Adam Czajczyk

    Hello Matt,

    I hope you're well today and thank you for your question!

    I have checked your "16yorkplace" site and I think it would be best to start with basic "tweaking". I'd suggest making this change to all the sites where backups fail.

    1. Increase allowed memory limit for WordPress by adding following line to the "wp-config.php" file of the site:

    define('WP_MEMORY_LIMIT', '128M');

    2. Adjust Snapshot to use smaller "chunks" of files and table data (that'll make backup process last longer but should decrease the chance for the script to time out):

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);

    All these lines should be put above the "/* That's all, stop editing... */" line in "wp-config.php" file. Once they are there, try running Managed Backup again and see if they complete. Let me know please about result and if necessary I'll investigate that further.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Matt!

    Thank you for your replay.

    We'll need to take it a step further then.

    Please add some more lines to the "wp-config.php" file then:

    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    
    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    These lines should also be located above the "/* That's all, stop editing...*/" one.

    Once they are there, please again disable scheduled backups and run backup manually. After it fails, download the "/wp-content/debug.log" file from your server (using FTP or cPanel's "File Manager" tool), rename it to "debug.txt" and attach to your replay here. Do not re-enable scheduled backups also.

    Make also sure please that the support access is still granted at that time (it's time valid so it may expire by then, just re-enable it in such case please).

    Hopefully, that will give me more insight into what is happening on site.

    Best regards,
    Adam

  • Dimitris

    Hey there Matthew,

    hope you're doing good and don't mind chiming in! :slight_smile:

    Did you search to /wp-content/ folder of "16yorkplace" installation?
    It should be the /wp-content/debug.log file by default, please advise!

    I can see in the error log of Snapshot though the followings:

    [Queue][2017-03-12 20:07:33][Warning] Processing a large file: /home/yorkplaceco/public_html/wp-content/backupwordpress-7158d94588-backups/16yorkplace-co-uk-1488983067-complete-2017-03-10-00-02-41.zip (740982957)
    [Queue][2017-03-12 20:07:33][Warning] Processing a large file: /home/yorkplaceco/public_html/wp-content/backupwordpress-7158d94588-backups/16yorkplace-co-uk-1489189631-complete-2017-03-10-23-55-20.zip (1915994250)

    Could you please try to exclude any large files that comes from previous backups procedures and test if this continues?
    You can do so via Snapshot -> Settings -> Global File Exclusions

    Also, please try to make a PHP variable change like
    max_execution_time = 300
    as described in a nice article from our blog here:
    https://premium.wpmudev.org/blog/increase-memory-limit/
    (you may have to contact your hosting provider about this, if you don't see the change you make in
    WPMUDEV -> Support -> System Info [button] -> PHP [tab] page)

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.