I simply cannot get featured images to be imported into the post

I can't get autoblog to add images to the posts. I have added Featured Image Import and Image Import activated but it still isn't working.

I have tried importing the feeds as excerpts and as full posts. With and without ssl verification. With and without a start date but it still doesn't work. Am I doing something wrong?

I also had this error message come up when I deleted a few of the pulled posts but it dissapeared when I refreshed.

Warning: Missing argument 2 for wpdb::prepare(), called in /home/username/public_html/community/wp-content/plugins/autoblog/autoblogincludes/classes/autoblogadmin.php on line 1604 and defined in /home/username/public_html/community/wp-includes/wp-db.php on line 990

Warning: Cannot modify header information - headers already sent by (output started at /home/username/public_html/community/wp-includes/wp-db.php:990) in /home/username/public_html/community/wp-includes/pluggable.php on line 876

I've added a screenshot of how my feeds are set up. Can you help please??