I think I'm missing something when trying to protect my pages with the Membership Plugin.

I have my Access Levels set up with the Membership Plugin and have added my short code "[level-member]" before the content I want just for members and "[/level-member]" at the end. I'm checking it in Chrome and Safari and and using Incognito Window in Chrome as well. However, in everything it's showing the shortcodes for membership and the shortcode for the video gallery that I'm trying to protect. What am I doing wrong? Thanks.

Here's the page I'm working with:
http://members.actssi.com/being-led-of-the-spirit/

  • Adam
    • The Incredible Code Injector

    Hi @rgmkrist,

    Bad news: yeah, it's really confusing.

    Good news: Turns out that's completely normal; because you're an Admin, you're seeing everything. In the top right region of the Admin Bar, you'll see a button that says, "Viewing Site as: …"

    Under that menu, you can choose to see the site as a user with different access, or even a visitor (with presumably zero-access).

    I agree, this could be much better documented. Took me several head-scratching minutes to figure it out, too. :slight_smile:

    Adam

    Screenshot: http://steppic.com/show/96fb93005379f5b9849272fc10b20e75.html

  • Vaughan
    • Support/SLS MockingJay

    hiya

    thanks for posting.

    @adam is correct for the most part.

    But when i visit that page as a visitor, i can also see the shortcode & protected content.

    have you set up your pages correctly and configured the subscriptions?

    could you also post a screenshot of your membership options (general options) and membership pages.

    this might help track down. it looks like you have no protected content at moment.

    did you also correctly set up the positive/negative rules for each level?

    thanks.

  • Joshua
    • Chief of Keepin' it Fresh Div.

    @rgmkrist - sorry about the confusion here. I hope what @Adam suggested solved your problem. If you are looking for a great indepth tutorial on this product WPMU DEV has created a very comprehensive video series. You can find it here: http://www.youtube.com/watch?v=AlmGpalbUyU&list=PLV1BcivFAIdtF4p7CYVfMbVAJ4JQ1Rpe9

    We are constantly trying to improve on the documentation and explanation of the products. I hope you find this information helpful. Cheers!

  • Paul
    • The Green Incsub

    @rgmkrist,

    Thanks for stopping by my Live support chat. I see the issue. Your shortcodes need to be cleaned up. It appears you have something inserting <span> elements. Here is the raw HTML source I'm seeing

    <p>[<span class="GINGER_SOFATWARE_correct">level</span>-member]</p>

    This needs to be only [level-member]. Same for the closing [/level-member] shortcode.

  • Adam
    • The Incredible Code Injector

    @rgmkrist

    I find that's a common problem (especially when pasting code I copied from an admin screen). As a best practice, I recommend always using shortcodes in the Code view. Less to worry about. :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.