I tried to use snapshot plugin to migrate a non multisite

Hello;
I tried to use snapshot plugin to migrate a non multisite wp (a normal wp) from local to server. Therefore I succesfuly did a snapshot in local, and I succesfully installed wp, snapshot plugin and my theme on server. I imported the .zip of my snapshot backup file sucessfully. But I am only able to see the home page of the site. The rest is not there!!
you can check it on:
bizilur.dreamhosters.com
Please help!! whats happening and how to solve? I imported and restored ALL THE FILES(I mean in the option of importing all, including blog posts, that shows up when you are importing and restoring snapshot backups.

thanks

  • Michelle Shull

    Hi, zenware!

    Oh no! Let's get this fixed!

    1. I'm definitely not seeing any images, but I know why. (Thanks for the note about how you're seeing them.)

    2. Check how the URL of your site changes to your IP address when you try to visit a new page. That means your DNS info isn't fully spread across the internet yet, or you have an error in your settings.

    Is the domain pointing towards the correct nameservers? (This is probably okay, since you can see some of the website. We'd get a 404 or a parked page, otherwise.)

    Is the A record pointing your domain to your IP address?

    Are there any old CNAME or A records pointing to a previous IP address?

    I think you got it all, your website just doesn't know where to look for your pages/images/etc. right now.

    Check your DNS settings with your domain registrar, whether that's your host or a third party.

    If that doesn't help, come back and we'll dig a little deeper. : )

    • zenware

      Well, it's a subdomain installation so no A or CNAME record problems, as they're the main domain's (or i think that should be).
      Anyway, the homepage works, part of the images are visible and part (the slider's) are not. If you right click on them to "open image in a new tab" you'll see the image url is a local url/path on those that cannot be seen and the hosted subdomain url in those that can be seen. THAT is a plugin issue as some of the database links have been updated to the new location and some not.
      I won't get into the 404 error you get when try to load any of the other pages... that's a different story.
      Well, any of the pages but 'Denda/Tienda' (that's the store page). That is not an automatically wp-generated main menu entrance but a custom one that was added by me, so it has a handcoded url that is stored in the database, just like the images urls are.
      If they keep pointing to my exact local (homesweethome/wordpress/wpcontent/...etc/etc/etc) instalation it's not a DNS record pointing in the wrong direction problem, but an url conversion failure of the snapshot tool imho. But i could be wrong.
      Apart from these issues, it would be nice to have any further answer too on this https://premium.wpmudev.org/forums/topic/7-flexmarket-theme-bugs-and-issues#post-748924
      Thanks for your time.

  • Tyler Postle

    Hey Zenware,

    I see your account has expired; however, just in-case you're still having this issue you can use a plugin such as this:

    https://wordpress.org/plugins/search-and-replace/

    then search the old url and replace it with your new one :slight_smile:

    There could have been an error in the restore, you could check your snapshot logs in-case.

    Hope this helps! Have a great weekend.

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.