i upgrade to last version. I receive this message Bad

i upgrade to last version.
I receive this message
Bad Request

Your browser sent a request that this server could not understand.
Apache Server at ygeia-enarmonisi.gr Port 80

The problem is that the site that is running is Holistic-Therapies.gr on a shared host with ygeia-enarmonisi.gr