I upload a logo to replace "spirit" logo, click okay, then click save, 2 and 3 times

Sorry, I'm not used to being so at the mercy of a plugin

I have been using iThemes "Builder" for 5 years.

I am trying "Upfront" and WPMU

I am following your Tutorial links

So I am using "Spirit" as per tuts

So it's all installed and first thing I click the "Spirit logo" and click to swap out with a new image

I upload my image. Click okay

then click "Save"

Then I click on the area we always do in top left corner to view our site

And my logo is gone, and only Spirit shows

So I go thru it again, 5 more times, saving each time

Why can't I view my work, one piece at a time?

Thank you :slight_smile:

Art

  • Kasia Swiderska

    Hello Art,

    Did theme saved correctly? I mean - was there message that says it saved (it would be like transparent box showing from the top of the page)?

    Can you try adding this following code to your .htacess file:

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    if that will not work would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Oldwaverider

    Thursday, 09/15/2016, 2:21 PM EST

    Yes Kasia, the little preloader image displayed showing that it was saving, and then when done, saved.

    I did it 6 times.

    And when I logged out of Upfront, and checked my WP Media files, it showed 6 copies of my logo that I uploaded and used to replace "Spirit", so it definitely went thru the process of uploading and saving.

    Your question >>> Can you try adding this following code to your .htacess file:
    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule><<<

    I WENT AHEAD AND ADDED THAT CODE TO HTACCESS FILE, BUT CAN U SEE IF I ADDED IN THE RIGHT PLACE?

    IN ORDER TO SHOW YOU, I NEED TO GIVE U A SCREENSHOT.

    How come this support thread doesn't have an image uploader so I can show you what I did?

    I mean that nicely by the way :slight_smile: It's just that all support tickets have image upload capability for screenshots, etc. So I'm a bit confused there, that you all don't have one :slight_frown:

    Okay, so here is what my htaccess code was before i added your code:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /special-frc/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /special-frc/index.php [L]
    </IfModule>
    # END WordPress

    Then I added your code below the above htacess code, but before the closing #END Wordpress tag. See below:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /special-frc/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /special-frc/index.php [L]
    </IfModule>
    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    # END WordPress

    That's pretty dangerous messing with htaccess files. Especially cause my security plugin Security Pro, once I install it, it is given permission to write to htaccess, though I havent' installed it yet, as this is my staging site.

    If I can get the design the way I want for my client, then I want to buy WPMUDEV membership.

    I will allow your access to site, after my late lunch I will follow your link, and do what needs to be done to grant access.

    Thank you Kasia !

    And I clicked, grant access to my site !

    Thank you for the help!

    Hopefully we can figure out why my first edit ever in Upfront won't stay in place :slight_smile:

    Art

  • Adam Czajczyk

    Hello Art,

    I hope you're well today and don't mind me jumping in :slight_smile:

    I took a liberty of accessing your site and experimenting a bit with it, including testing other Upfront theme. I noticed some console errors there and usually errors of that kind can be solved by switching "mod_security" Apache module off. That's supposed to be done by the .htaccess code that Kasia suggested.

    However, that code may not work everywhere (on every server) and there's still a chance that this is a different issue.

    Having that said, I'd like to ask you to give following steps a try:

    1. review your server's cPanel (or the server management panel that's available for your) and look for "mod_security" settings; if there's such option turn "mod_security" off for that domain;

    2. if there's no option to do that, please get in touch with your host and ask their tech staff if they could either turn it off for your account or at least "white list" your domain.

    If that cannot be done or they confirm that "mod_security" is disabled but it still doesn't work:

    3. Switch PHP to a newer version (7.x possibly); usually this can be done with a setting in cPanel or by asking host staff

    Could you give it a try please? Let me know about results.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.