I use Autoblog to import Facebook posts to my website.

I use Autoblog to import Facebook posts to my website. A few weeks ago Hoang posted a cached image fix that ensured the large Facebook image was imported rather than the thumbnail image. I applied this fix and it worked great for awhile, but I noticed that recently thumbnail images are being imported again instead of full size images and all of my previous imported images are now thumbnails. I haven't changed any settings that I am aware of to make this happen.

I have tried deleting the current Autoblog Facebook RSS feed and setting it up again, deleting original imported posts and re-importing and re-generating the images, but nothing works - only thumbnail images are being imported.

Here is my Facebook RSS feed: https://www.facebook.com/feeds/page.php?id=729076663779895&format=RSS20

And here is an imported post with a thumbnail instead of the large size image: http://www.abergavennybabywearing.com/lets-kick-off-2015-with-a-giveaway-details-coming-later-today/

Thanks for your help. Hoping this can be easily resolved.