I use the Customizr

I use the Customizr theme. I've installed Hustle to create pop ups for my page. I created one to integrate with MailChimp. I don't think it's working. I have it set to pop up on all posts and 2 pages. I've tested it through an incognito page and I've asked my husband to test it on his computer. I've cleared the cache and still nothing. I looked through the forums but I am a code idiot and I'm having trouble figuring out what to do...

  • Adam Czajczyk

    Hello Claire,

    I hope you're well today and thank you for your question!

    I have just tested Hustle with Customizr theme on my end and it worked - popups that I created were displayed on the site as expected. I do not know, however, about your configuration so it's possible that this is either specific to the way these popups are set up or it's a matter of some other aspect of your site.

    Having said that, I'd like to check it and for this, I'd need to access your site. Would you mind enabling a support access for me?

    You can do this by following this guide:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Let me know when it's open, please.

    Best regards,
    Adam

  • Denitsa

    Hello Claire,
    I hope you're doing great!:slight_smile:

    I went ahead and accessed your site (thanks for granting the support access). What I noticed is that I can't create a new Opt-in, I get to this page:

    If you want to give this a whirl, you can make a basic theme/plugin conflict test. To perform it, please follow all the steps described on a flowchart in this article (you may need to scroll the page down a little):
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    This will point us toward a plugin (or your theme) that might be causing a conflict here.

    Next, I tried installing a plugin to view the debug log (you need to have some code manually added to wp-config.php for the plugin to display the actual log) as a test of how plugin installation is behaving on your site. While installing and activating went well, I can't seem to be able to disable to delete it now and this points us to some issue with your backend.

    What I also noticed was that you're on a rather old PHP version - 5.5.22. This version is at its end of life and is no longer supported.:slight_frown:
    I'd recommend updating to at least 5.6+, the current standard being 7+ (you can see here), as having an older version can not only interfere with the overall work of WP, but also pose a security threat for the site.

    Going back to the debug.log part, will you please access your server through FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);

    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    The log will be saved to a debug.log file inside the "/wp-content" folder. Please save the file as a .txt and attach it to your next post.
    If the file's larger than 5MB you might need to upload it somewhere like Dropbox and share the link here.

    Let me know how it all goes!

    Cheers,
    Denitsa