I want to hide the first Avatar option on the Profile page using Ultimate Branding

I’m using Ultimate Branding to change the appearance of the profile page. I’ve already applied some different changes on it. Now I would like to hide the ‘Custom Avatar’ option from the ‘Display this Avatar’ section, but I’m not able to achieve this.

  • Predrag Dubajic
    • Support

    Hi Carl,

    Hope you're doing well.

    Adding this CSS in the browser does the trick:

    #avatar-manager tbody tr:first-of-type td fieldset > label:first-of-type {
        display: none;
    }

    However it doesn't load when added to Ultimate Branding Admin CSS field, and when I checked the rest of the code in there it doesn't get loaded as well so it looks like something is not allowing UB to do its job.

    Can you disable your other plugins and see if Admin CSS is applied after that so we can see if there's some conflict with one of your other plugins.

    Best regards,
    Predrag

    • Carl Martin
      • Flash Drive

      That does work. The reason you're not seeing it is because I have code in the Ultimate Branding Plugin that makes changes in the CSS Module affect ONLY Subscriber level users. If you log in as a subscriber, it works!

      How would I go about moving the Avatar section below the one you just hid up so it's even with the "Display this avatar" title?

  • Predrag Dubajic
    • Support

    Hi Carl,

    If I understand correctly you wish to move the avatar selector a bit upwards so it aligns like this:

    If that's the case adding this CSS should do the trick:

    #avatar-manager tbody tr:first-of-type td fieldset br {
        display: none;
    }
    
    #avatar-manager tbody tr:first-of-type > td {
        padding-left: 5px;
    }

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.