I want to only show busy or free in calendar

I only want to show free or busy in the calendar;
where do I change this setting? i.e I don't won't not available as an option

  • PC

    Hello Walter,

    Thanks for posting on the forums.

    Appointments plus is designed to display Free, Busy or Not possible according to your Selection.

    If you want to change it from Free to Available, you will need to make core changes in the plugin or simply use the language files to translate text and replace it with the words you want.

    For not possible, you will need to make sure your working hours are set to 24 hours.

    For filling up the slots you can use Google calendar integration where if it will sync with your calendar and show the free and busy slots accordingly.

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers
    PC
    Sales &Support

  • pxwm

    Hi @PC - Hope you don't mind me making a suggestion

    Hi @Walter

    if I have understood your requirement you could try the following:-

    Login to the Wordpress dashboard as Admin
    Select A+ Settings
    Select the 'General' tab
    Scroll down to the 'Additional css Rules' field
    Add the following code:-

    .notpossible{display:none !important;}

    Save the settings
    Logout of Admin
    Open your Appointment page and refresh
    Then check and it should remove all the 'Not Possible' dates and times

    Hope that helps
    Regards
    SteveB

  • walter

    Hi Steve and PC,

    I tried Steve's solution and although it removed the not possible option it also messed up the calendar and left the label not possible as per this image:
    http://www.whitewolfjourneys.com/appointmentserror.jpg

    "For not possible, you will need to make sure your working hours are set to 24 hours." ; it's not clear to me what you mean. In the working hours tab, I have defined the working hours...

    Sounds like using Google calendar to control availability is an easier option....

    thanks for your help
    Walter

  • pxwm

    Hi @walter

    I understand and you may wish to try the following:-

    Login to the Wordpress dashboard as Admin
    Select A+ Settings
    Select the 'General' tab
    Scroll down to the 'Additional css Rules' field

    Remove the following code:-

    .notpossible{display:none !important;}

    Then Add the following code:-

    .notpossible {color: #ffffff;}
    .notpossible p{color: #ffffff;}

    The 1st line will hide the 'not available' times
    and the 2nd line will hide the 'not available' days
    the ffffff is based on the background colour of the image you provided

    Save the settings
    Logout of Admin

    Unfortunately I don't think there is an easy way to remove the actual 'not possible' legend without changing the plug-in code but the scheduler does look better.

    Open your Appointment page and refresh
    Then check and it should remove all the 'Not Possible' dates and times

    Please let me know if this works for you

    Regards
    SteveB

  • PC

    Hello Walter,

    Unfortunately it worked too well as it messed up the display of the calendar by only showing available and busy days, times but not adhering to displaying them in the relevant row or column.

    That is sad :slight_frown: Hiding them via CSS is not a good idea.

    This can be a good feature to include in the plugin where we can select what all we want to display on the frontend.

    Let me move it to "Features and Feedback" category and send a note to our lead developer. Then depending on the number of votes, the developer can decided the usefulness of the feature and it can be included in the future versions of the plugin.

    Cheers
    PC
    Sales &Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.