I was trying out the WP IOS, and out of the box without any

Hi, I was trying out the WP IOS, and out of the box without any changes to the settings I get this error:

Ld /Users/miguelmadeirarodrigues/Library/Developer/Xcode/DerivedData/WordPress-eecgwdyytczpcdggrwjalwwrobvb/Build/Products/Debug-iphonesimulator/Edublogs.app/Edublogs normal i386
cd /Users/miguelmadeirarodrigues/Downloads/wp-for-ios-2/ios/WordPress
export IPHONEOS_DEPLOYMENT_TARGET=6.0
export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:disappointed:Applications/Xcode.app/Contents/Developer/usr/bin:disappointed:usr/bin:disappointed:bin:disappointed:usr/sbin:disappointed:sbin"
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -arch i386 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator8.1.sdk -L/Users/miguelmadeirarodrigues/Library/Developer/Xcode/DerivedData/WordPress-eecgwdyytczpcdggrwjalwwrobvb/Build/Products/Debug-iphonesimulator -F/Users/miguelmadeirarodrigues/Library/Developer/Xcode/DerivedData/WordPress-eecgwdyytczpcdggrwjalwwrobvb/Build/Products/Debug-iphonesimulator -F/Users/miguelmadeirarodrigues/Downloads/wp-for-ios-2/ios/WordPress/../Pods/google-plus-ios-sdk/google-plus-ios-sdk-1.3.0 -F/Users/miguelmadeirarodrigues/Downloads/wp-for-ios-2/ios/WordPress/Classes -F/Users/miguelmadeirarodrigues/Downloads/wp-for-ios-2/ios/WordPress -filelist /Users/miguelmadeirarodrigues/Library/Developer/Xcode/DerivedData/WordPress-eecgwdyytczpcdggrwjalwwrobvb/Build/Intermediates/WordPress.build/Debug-iphonesimulator/WordPress.build/Objects-normal/i386/Edublogs.LinkFileList -Xlinker -objc_abi_version -Xlinker 2 -ObjC -liconv -lsqlite3 -lxml2 -lz -framework Accelerate -framework CoreGraphics -framework CoreTelephony -framework CoreText -framework Foundation -framework GoogleOpenSource -framework GooglePlus -framework ImageIO -framework MediaPlayer -framework MobileCoreServices -framework QuartzCore -framework Security -framework SystemConfiguration -framework UIKit -weak_framework AdSupport -fobjc-arc -fobjc-link-runtime -Xlinker -no_implicit_dylibs -mios-simulator-version-min=6.0 -framework Social -framework MobileCoreServices -framework SystemConfiguration -framework AudioToolbox -framework CoreGraphics -framework UIKit -framework QuartzCore -weak_framework Accounts -framework AddressBook -framework MediaPlayer -framework CoreMedia -framework AVFoundation -lz -framework Foundation -framework Security -framework MapKit -framework CoreLocation -framework CoreData -framework CFNetwork -weak_framework AssetsLibrary -framework MessageUI -liconv -framework ImageIO -lPods -framework Crashlytics -Xlinker -dependency_info -Xlinker /Users/miguelmadeirarodrigues/Library/Developer/Xcode/DerivedData/WordPress-eecgwdyytczpcdggrwjalwwrobvb/Build/Intermediates/WordPress.build/Debug-iphonesimulator/WordPress.build/Objects-normal/i386/Edublogs_dependency_info.dat -o /Users/miguelmadeirarodrigues/Library/Developer/Xcode/DerivedData/WordPress-eecgwdyytczpcdggrwjalwwrobvb/Build/Products/Debug-iphonesimulator/Edublogs.app/Edublogs

ld: library not found for -lPods
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Can you give support with this?

Thanks

  • Jack Kitterhing

    Hiya @Miguel,

    Hope you're well today and thanks for your question, it appears that Pods isn't installed, it's possible it's installed, but not found, though usually it's the former.

    Can you open up terminal on your Mac and then type the following exactly.

    sudo gem install cocoapods

    Then press your "enter" key. Wait a few minutes for pods to install, it may ask for your admin password, when/if prompted type that, please note that in terminal you won't actually see your password typed out, once typed out press "enter" again for the installation to continue.

    Once done, clean the build and restart Xcode, it should work correctly then.

    @Mathias Apologies about the delay on your thread, I've just seen it and will respond in a moment.

    Thank you!

    Kind Regards
    Jack.

  • Bruno

    gem list --local | grep cocoapods
    /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/universal-darwin14/rbconfig.rb:213: warning: Insecure world writable dir /usr/local in PATH, mode 040777
    cocoapods (0.36.0.rc.1, 0.35.0)
    cocoapods-core (0.36.0.rc.1, 0.35.0)
    cocoapods-downloader (0.8.1)
    cocoapods-plugins (0.4.1, 0.3.2)
    cocoapods-trunk (0.5.1, 0.4.1)
    cocoapods-try (0.4.3)

    I have performed the sudo gem install cocoapods --pre
    and inside "ios" folder the touch Podfile and pod install
    the pod install gave the following
    "/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/universal-darwin14/rbconfig.rb:213: warning: Insecure world writable dir /usr/local in PATH, mode 040777

    [!] Invalid WordPressApi.podspec file: undefined method `documentation=' for #<Pod::Specification name="WordPressApi">. Updating CocoaPods might fix the issue.

    # from /Volumes/Mac Xpress SSD/xcodedev/ios/Pods/Local Podspecs/WordPressApi.podspec:18
    # -------------------------------------------
    #
    > s.documentation = {
    # :appledoc => [ 'AppledocSettings.plist' ]
    # -------------------------------------------
    "

    And compiling (run) gives the following build error:
    #import <AFNetworking/AFNetworking.h> (File not found)

    I will try some other combinations of gem install and target etc but so far the same error...
    not a clue, any advice ?

  • Jack Kitterhing

    Hiya @Bruno, @Miguel and @Mathias,

    Hope you're well today, glad to hear you got up and running with the edublogs version, that is effectively the same version, though the one here has some minor differences, with regards to the configuration files.

    I've been discussing this with a colleague and I wanted to check, before compiling, are you cleaning the project?

    As this morning when trying to replicate again, I downloaded fresh and made my changes (app name etc), then I got the same issue with regards to "ld: library not found for -lPods
    clang: error: linker command failed with exit code 1 (use -v to see invocation)"

    After cleaning and then compiling it worked. We'd love to get this working for you all. :slight_smile:

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.