Iam having issues

Hi!
Iam having issues with my SSL , Some images still load via the http and not the https

have a look here
https://i.imgsafe.org/7dc2cceb97.png

Please let me know how i can force https for images and get the ssl to validitate

Thanks

  • James Morris

    Hello Steven,

    I hope you are well today. Thank you for your question.

    This is a very common issue when you've moved your site from http:// to https://. The vast majority of the time the culprit is the WordPress Theme Customizer. The first two images in that report have "LOGO" in their file paths, so I suspect this is very much the case. The other image could be in the Theme Customizer as well, but may be in the body of your content.

    What you'll need to do is login to your Admin Dashboard -> Appearance -> Customize
    Go through all your options. Wherever there is an image defined, just remove it and re-add it via the Media Library.

    This will update any database references from the http:// protocol to the new https:// protocol. If you still have any issues remaining, then it is likely a hard-coded URL string in either your theme or content that needs updated. To update those, go through your posts and check the paths of the images in the WordPress editor in Text mode and simply add the s to the http.

    For any images that are hard-coded with the http:// url, you'll need to either use FTP or the WordPress theme editor to update those files. A common place is in setting a background for your page in the CSS.

    Let me know if you have further questions. I'll be happy to help! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.