IE issue when using default Wordpress Password Protected page

I have a site that has a password protected page created using Wordpress' default options and I've had my client tell me that they're getting an error in Internet Explorer saying this:

To display the webpage again, the web browser needs to resend the information you've previously submitted.
If you were making a purchase, you should click Cancel to avoid a duplicate transaction. Otherwise, click Retry to display the webpage again.

Any idea why this is happening? So far I've only seen it in Internet Explorer. Is this a bug with Wordpress?

  • Kasia Swiderska
    • Support nomad

    Hello Tom,

    That is very strange message and other staff members were not able to replicate this issue in IE.

    What IE version it is? Does thins happen when all add-ons in IE are disabled? Have you try to run plugin/theme conflict test illustrated in getting support manual (flowchart)
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    I did research that issue but it does not show in regarding to WordPress - but to ASP and JavaScripts.

    kind regards,
    Kasia

  • Tom Powell
    • Site Builder, Child of Zeus

    I can send you the pages that I've been trying. I have two pages that have password protections on the content. Do you have a way I can privately send this information to you?
    I noticed now that it is also not working in my Chrome browser. It just says that 'You are being redirected' and I see a white page.

    What is ASP? And did it give any solutions for it if it was an ASP/Javascript issue?

    thanks.

  • Tom Powell
    • Site Builder, Child of Zeus

    Ok, I got to the point where I needed to look for other plugin options that will accomplish the same functionality so I've installed Password Protect and tried it with that, and its still not taking my password. Can someone advise please?

  • Kasia Swiderska
    • Support nomad

    Hello Tom,

    Can you enable access to those sites so we can check those? You can leave in message for support url to those pages with password to check.
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I tested just Password Protected on my lab site and it works without problem in Chrome.

    Did you run plugin conflict?

    White screen usually suggests there is error on site - so if plugin conflict didn't give any positive results enable debug log in your WordPress. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it. I would need then to see contents of the debug.log file - so please upload it to service like a Dropbix and paste link here.

    kind regards,
    Kasia

  • Tom Powell
    • Site Builder, Child of Zeus

    I've enabled access, the site is reh-fit.com. I have duplicated the site to test on our own hosting server (because currently the site is hosted elsewhere) and I didn't get any issues with it. But the live site (reh-fit.com) is still not working. I also can't disable all the plugins because this site is live right now. I did add the WP_DEBUG lines that you suggested to put in the config file. I'll send a message to support with the password-protected pages and their passwords so you can check them out. Thanks

  • Kasia Swiderska
    • Support nomad

    Hello Tom,

    Did you had a chance to check that debug log? I can see issue on your site but I can't replicate it. Another thing is that staging site is working on different server - that can lead to conclusion that this is server issues (can you check if php version is the same on both servers?). Hopefully there will be more information in debug log that will tell us more about nature of that issue.

    kind regards,
    Kasia

  • Tom Powell
    • Site Builder, Child of Zeus

    Hi Kasia,
    I have the debug log file, I'm not sure how to decipher it. Can I send it to you somehow?
    I also tried changing the php version, because the site was originally at php version 7. I bumped it down to version 5.3 to see if there was any chance and I was still having the same problems.
    thanks,

  • Nithin
    • Support Wizard

    Hi Tom Powell,

    Hope you are doing good today. :slight_smile:

    You can make use of the cloud services like Dropbox, or Google Drive, and share us the link to your debug log file in your next reply. Thanks for testing it with different versions of PHP, this is quite an odd issue, looking forward to see whether the debug.log files has any errors related to this issue. Please do let us know, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Tom Powell
    • Site Builder, Child of Zeus

    Hi Nithin,
    After all the testing I have done, I found out yesterday that the hosting company had a firewall up for this website and that was preventing the password-protected pages from working. That's why nothing I did was working. Now that they disabled the firewall, it seems to be working again. Thank you for looking into this though!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.