I'have problems with the google calendar sync. There are mistakes

I’have problems with the google calendar sync. There are mistakes on the dates. Some hours are free on google calendar and in my appointments + calendar seems to be occupied, and viceversa. The log is clean and there is everything all right, with no error messages.

My calendar is not primary, and my google account is not bussiness

What can I do? Thank you very much in advance

  • Vaughan
    • Support/SLS MockingJay

    Hi Ade,

    Hope you're well?

    It looks like everything is set up ok, though you do have it set so that service providers can use their own calendars, I checked on the profile for the only provider you have & it is set to disabled. This might be the reason.

    As you only have one provider, it would be better if you changed the option in the GCal settings

    Allow Service Providers for Google Calendar API Integration – Set to No.

    Give that a try, if that still fails, we can look at the Cron job itself, as that relies on the amount of visitors to your site, the more visitors, the better the cron works, however it's possible to actually disable WP cron which relies on visitor counts, and setup a real cronjob in your servers CPanel which would be more reliable and not dependant on the amount of visitors.

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.