I'm getting a connection error with WHMCS provisioning plugin

I have double checked all of my settings and everything appears to be correct. Yet when trying to accept an order in whmcs I'm getting the following error:
Order Accept Encountered Problems
Connection Error: 6 - Couldn't resolve host 'http'

I'm not sure why its trying to resolve that host, it appears something is wrong in the module settings and they are as follows:
hostname: http://wordpressinstalled.com/zhi3apprentice
I have tried it with and without the http and the trailing slash yet I get the same results.

I'm not sure what the problem is. the whmcs setup is on http://wordpressinstalled.com/order/

THanks for your help!
~Blaine

  • Timothy Bowers

    In WHMCS where it wants the hostname, it just needs the domain and not the full URL.

    Can you change that and then please test again.

    Let me know.

    Hey @tom.eagles

    Probably a really silly question but when i was speaking to my hosts about going down this route they told me that whmcs was possible but i would need a license from whcms in order to do the provisioning through their console on the server just having a reseller account wouldnt be enough as they would be recieving the funds. I am assuming you have this sorted already?

    Why is that?

    With their reseller accounts do you not have control and access to the actual install or something?

    By that I mean the files?

    If you do then it should just be a case of adding our modules unless I'm missing something here?

    Take care.

  • Tom Eagles

    hey @timothy if you want to have the payments come direct to you with my host you have to have your own whcms and license setup. otherwise their payment system handles it all. kinda screwed up but as i am not planning on reselling the web space its ok. The main reason i went with them originally was because they were a specialised video streaming provider. but as it is i am looking to move to joe as a host when some of my bigger invoices finally get paid :slight_smile:

  • mariawhalen

    I took out the http:// and it registered, which is strange because I had already tried that and it finally worked. however the domains didnt map properly and I cant actually get to the site at the moment.

    May still be because I had the sub directory or something, check out the screenshots.

    Also when WHMCS provisions shouldn't it insert the users login and password from there? it may be messing up because I'm using the blog template plugin... which I'm sure I can check, but the domain mapping is an issue if you could help that would be awesome!

    ~Blaine

  • Timothy Bowers

    Hey there Tom.

    Maybe that's how many work, I don't know. But I'd rather get a license than them be so restrictive. You could then use services like eNom to sell domains and space.

    Hey @blaineglynn

    Allowing original domain in the mapping options will let you access the sites admin to remove it.

    Under the module settings in the WHMCS can you please remove the Default Blog Domain then try again and see how it works. It looks like you have a full TLD type link in there.

    Let me know if that then works for new sites.

    For the one you created, you'll need to remove it as I described. If for some reason you still can't access that site then you'll need to edit the DB.

    Let me know how you get on.

    Take care.

  • mariawhalen

    Timothy:

    Well I can now create sites just fine. However I noticed because my MU was setup on a subdirectory it defaulted to always wanting to create the new sites (even with a mapped domain) as a subdirectory.

    Furthermore I can't for the life of me get the mapped domains to work. I have read over the docs and the forums multiple times but its not clicking for some reason.

    Here are a couple of the questions I have:

    I have a dedicated IP for my server, do I need to get a new one specifically that points to the MU install as the top level domain(possibly not the correct term)?? (IE the domain that pulls up when you type in the ipaddress?)

    Also, my setup uses ENOM to register the domain name and then points it to my nameservers....

    Do I have to set up any other A records or anything with these new "sub site domains" in order to make sure they are pointing to my MU install?

    On those lines, do I want to park those domains or set them as an addon in my Cpanel to assure they are forwarding correctly?

    Please let me know if some of this was not as clear as it could have been...
    IP address of my server:
    "sub account domain" zhi3fusioncoaches.com
    Sub account in MU http://nielsenzeal.com/zhi3fusioncoaches/

    Thanks in advance for your help, this domain mapping is driving me crazy and I just want to get it up and working!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.