I'm getting an "FNAME must be provided" error when emails

I'm getting an "FNAME must be provided" error when emails are entered.

  • Alexander

    Hi @habicht,

    I'd be happy to look into this for you. Thank you for providing the screenshots. I'll need to do some testing here. To start can you please confirm that you're using both the latest version of Wordpress (3.6) and the latest version of Slide In (1.1.3) ? Then I can create a test site for this.

    Also, can you ensure that you aren't getting any errors on the Wordpress side of things? You can do this by enabling debug mode and debug logging. Here is a helpful snippet you can place in your wp-config.php file to do this: http://git.io/gJANNQ

    Best regards,

  • habicht

    Yes, confirmed Wordpress 3.6 and Slide In 1.1.3.

    Debug mode is enabled.

    FYI: From WPEngine (my host), "When hosting your website with WP Engine, you might notice that every page will have the following warning while debug mode is turned on:

    Warning: include() [function.include]: Failed opening '/nas/wp/www/cluster/account/wp-content/advanced-cache.php' for inclusion (include_path='.:disappointed:usr/share/php:disappointed:usr/share/pear') in /nas/wp/www/cluster/account/wp-settings.php on line 62
    Because the define('WP_CACHE', true); setting is enabled in wp-config.php, WordPress attempts to load the wp-content/advanced-cache.php drop-in. Our caching configuration does not need to leverage this file, however. That means the file doesn’t exist on sites hosted here and this error crops up while debugging things.

    While any error is normally a cause for concern, this warning can be safely ignored."

  • Alexander

    Hi @habicht,

    I'm very sorry about the delay here. Thanks for the debug log information.

    I've tried this on a test site with the latest version. I've tried just about every combination of settings, but wasn't able to reproduce the issue.

    Can you confirm whether this is happening when you are logged in or logged out?

    Also, can you check the javascript console for errors? In Chrome go to "View -> Developer -> Javascript Console" and in Firefox you can go to "Tools -> Web Developer -> Console"

    Try opening the console, then trying to subscribe via the form. See if any errors are generated.

    If you'd like I can also log in to take a look. If this is ok you can send login info via our contact form: https://premium.wpmudev.org/contact/
    - Choose "I have a different question"
    - Include my name in the subject "Alexander Rohmann"
    - Include any relevant login information

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.