I'm having issues with "double bookings" with a multi-service, single-provider setup

I have appointments+ setup for a single-provider that has nearly 50 services that they provide (it's a day spa). I have two way synchronization setup with their Google Calendar, as they manually add appointments to their Google Calendar.

By default all appointments that are manually inserted in their Google Calendar show up in Appointments+ as "30 Minute Massage", which is also the first service in the service list.

I'm having an issue of double bookings. Even though they put an appointment in on their Google Calendar, a client is not able to book a "30 Minute Massage" on the site, but if the client chooses another service, such as "60 Minute Massage", every availability is open.

How do I fix this? I have one service provider providing all of these services and appointments are starting to overlap!

To see what I mean, you can visit here: http://lavishinsequim.com/schedule-an-appointment/

TIA!

  • Tyler Postle
    • CGO

    Hey NWTD,

    Hope you're doing well today and thanks for your question!

    Is the double booking occurring within a small time frame from when the appointment gets added through Gcal? Appointments added in Gcal don't get imported into appointments right away, approx 10 minutes - unless you click the "Import" button on the Appointments+ Gcal setup page :slight_smile:

    Since you have 1 service provider, are all services capacities set to "0"? This means it limits to the amount of service providers available.

    Look forward to hearing back!

    All the best,
    Tyler

    PS. We recently released a new version too so you can upgrade to 1.4.6 too :slight_smile:

  • NWTD
    • The Incredible Code Injector

    Thanks for the quick response Tyler.

    There's been a few hours between manual appointment making and the overlapping appointment.

    I just tried changing the capacity to 0 for all services; this didn't manke nay difference. I also cleared all caches I have (using W3TC).

    I just now updated to the latest version, that made no difference.

    Any other suggestions?

  • Tyler Postle
    • CGO

    Hey NWTD,

    My mistake, I didn't realize it was a mapped domain, support access logs us out when trying to navigate to a new domain after login. Cookie issue I believe.

    Easy enough to get around though, do you mind sending the login credentials in through our private contact form?

    Send in: https://premium.wpmudev.org/contact/

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    That way I can just login normally as you would and shouldn't have a problem :slight_smile:

    I'll keep an eye on my inbox for the email. Post back in this thread too just in-case.

    Talk to you soon!

    Cheers,
    Tyler

  • Tyler Postle
    • CGO

    Hey NWTD,

    Thanks for sending that in :slight_smile:

    I just added a parameter into your shortcode:

    [app_monthly_schedule worker="43"]

    To ensure it forces your service provider, it could be seeing the "No Preference" provider as another option, which it shouldn't be but just want to make sure :slight_smile: can you check if it's working correctly now?

    Is it only happening with the Gcal appointments?

    Look forward to hearing back!

    All the best,
    Tyler

  • NWTD
    • The Incredible Code Injector

    Thanks Tyler. This doesn't seem to fix the issue =/

    It does appear that it's only the Gcal appointments. I had two appointments booked over the weekend -- that are not "30 Minute Massage" service -- and those times are not available for any other services.

  • NWTD
    • The Incredible Code Injector

    Tyler, your last suggestion about Gcal may be on the track to the issue. I noticed all the appointments under "Reserved by Gcal" are all set to the provider "Our Staff".

    The Gcal integration is setup in the Appointments+ settings, but I notice that there's an option in the user profile to setup integration.

    What's the proper way to get the currently "Reserved by Gcal" to point to the proper user, and make sure that all future "Reserved by Gcal" are assigned to them as well?

    FWIW, there will never be more than the one current provider.

  • NWTD
    • The Incredible Code Injector

    Interesting note -- I tried to configure the Google Calendar API in the user's profile, and all fields are grayed out, and I'm unable to set integration mode (the option resets to disabled when you attempt to save changes).

    Thanks for your help and input thus far.

  • Tyler Postle
    • CGO

    Hey NWTD,

    Thanks for the updates there :slight_smile:

    I was thinking that setting it up for your specific provider profile would be a good because then it should also assign it directly to you.

    You mentioned that the fields are grayed out, I just logged in to check that because on my installation they are fine and they look to be good on yours too? I'll attach a screenshot :slight_smile:

    Are you seeing something else on your site?

    If so, let me know which browser you're using.

    Look forward to hearing back.

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.