Snapshot isn't creating archives

I'm having some issues with Snapshot. I have 2 different types of snapshots set. The first snapshot is an immediate backup of everything, so I can just click 'run now' and it will back my whole site up, say before a plugin upgrade. This saves to my server. The second snapshot is a scheduled weekly backup, set to run every Friday morning and save to a specific folder on Google Drive.

The first problem is that the 'log viewer' doesn't work. If I select 'run now' the window pops up and say loading, but nothing ever materializes. If I close the window and refresh the page. The 'creating archive' section next to that snapshot disappears. Nothing is saved.

This is true for both the local server and for Google Drive. My Google credentials are good and the location I want to save to authenticates properly, but nothing gets saved there. When I run a snapshot.

I have some old snapshots. It looks like the plugin hasn't worked correctly since Jan/Feb this year.