I'm having troubles installing a child theme. WP Admin

I'm having troubles installing a child theme. WP Admin shows an error message saying it can't find the parent theme even though I used the same child theme format in another theme on the same domain before that worked.

Why?
Thanks
Joe

  • Tyler Postle
    • CGO

    Hey Joe,

    Hope you're doing well today!

    So you have the child theme folder in the /themes folder? I can see you also have Divi installed, which I believe is the parent theme in this case right?

    Can you double check your child theme CSS file and make sure that it has the line:

    Template: divi

    Inside the top commented section? it may look something like this:

    /*
     Theme Name:   Divi Child Theme
     Description:  Divi child theme
     Author:       John Doe
     Template:    divi
     Version:      1.0.0
    */

    Let us know if you're still having any issues here Joe!

    All the best,
    Tyler

  • Tyler Postle
    • CGO

    Hey Joe,

    Hope you're doing well today! Just to clarify for future reference, the reason the original you had wasn't working is because you have the "template: ", which is the parent theme, written as "MCS2-Divi" - so it will search the themes folder for a folder called that.

    When really you want it to search for one called just "Divi" :slight_smile:

    Hope that helps! Enjoy the rest of your weekend Joe.

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.