Caching Error

Hi,
I'm trying to enable caching but I'm getting the following error:

Browser Caching is not working properly:
- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
- Another plugin may be interfering with the configuration

I've checked with my host and they've said module deflate is installed. Any ideas what could be going wrong?

  • Predrag Dubajic
    • Support

    Hey Jamie,

    Hope you're well and apologies for the delay here.

    Have you already tried disabling your other plugins to see if there's any conflict on that end?

    This might be a silly question but just to be sure, your host told you that deflate module is installed, did they confirm that it's also enabled?

    Also, would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Please respond in this thread once access is granted.

    Best regards,
    Predrag

  • Jamie
    • Flash Drive

    Hi Predrag,
    Thanks for your reply.

    I've asked my host to confirm whether deflate module is enabled or not. I'll let you know as soon as they get back to me.

    I've disabled all plugins and tried again, but the same error message appears.

    I've granted support access for you to take a look. Hopefully it'll be something as simple as the deflate module not being enabled!

    Many thanks.

  • Predrag Dubajic
    • Support

    Hi Jamie,

    Thanks for granting access, I had a look at your installation and there's not any additional info that could point us in different direction.

    Some hosts disable caching changes to be made via .htaccess rules (which is how HB does it) but in those cases the error is usually not shown.
    So that's most likely not the case here but it's also worth checking with your host just to be sure.

    Let us know of your host response.

    Best regards,
    Predrag

  • Jamie
    • Flash Drive

    Hi Predrag,

    The host replied saying the Apache modules are installed but I needed to add code to the htaccess file. I've added the 2 codes as they instructed (one for gzip compression and one for caching) but the error message is still appearing when trying to enable gzip and caching in Hummingbird.

    The host also said:

    If you wish to enable deflate compression on the website you can use a code in .htaccess for this purpose. For such a code you can check with your web developer as he should be able to advise on this.

    I'm guessing this code is what Hummingbird writes to htaccess when I press enable?

  • Predrag Dubajic
    • Support

    Hi Jamie,

    That's correct, HB adds the code rules in .htaccess in order to enable both Browser Caching and GZIP Compression.

    I had another look at your site and did a scan on google page speed and it looks like both browser caching and GZIP compression are properly enabled on your site but something is blocking HB from getting this result properly, this could be due to server forbidding self http requests.

    So basically, browser caching is working properly on your site but the info is not displayed correctly inside HB.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.