I'm trying

I'm trying to update some WPMUDEV plugins, and my whole dashboard is blank. I have turned on support through the website a few times, but maybe it isn't going through.

I have support access turned on now.

  • James Morris

    Hello atracksler,

    If your whole Dashboard is going blank when you go to perform updates, this usually indicates a code issue that is causing a PHP Fatal Error.

    In order to help you better with your issue, would you please grant me access to your site and server so I can perform some advanced debugging?

    Also, do I have your permission to attempt to perform the updates that are failing on your site?

    NOTE: Please make a full backup of your site before sending the following information.

    Please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    ~OR~

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • James Morris

    Hello atracksler

    After further investigation, I found that your configuration for Bulletproof security was much too restrictive. It was limiting access to resources needed by WPMU DEV Dashboard.

    In public_html/wp-content/plugins/.htaccess I had to add the following whitelist rules:

    RewriteRule ^wpmudev-updates/js/modules.js - [L]
    RewriteRule ^wpmudev-updates/shared-ui/wdev-ui.js - [L]

    You also have the following defines in you wp-config.php which are slowing the performance of your site significantly:

    @ini_set('memory_limit','275M');
    @ini_set('max_execution_time','30');
    @ini_set('mysql.connect_timeout','30');

    I have left these in place, but the following would be better:

    @ini_set('memory_limit','512M');
    @ini_set('max_execution_time','180');
    @ini_set('mysql.connect_timeout','180');

    Finally, your default security keys were set with placeholders, which is terribly insecure. I did update these for you by grabbing a new set from https://api.wordpress.org/secret-key/1.1/salt/ This will only invalidate old cookies. This will have no effect on login details.

    While the site is terribly slow with the restrictive PHP setting in place, I did manage to verify that WPMU DEV Dashboard is working correctly and I was able to update the 2 plugins of ours that had updates available to them. I did not update any other plugins on your site, though.

    Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

  • James Morris

    Hello atracksler

    BPS security is basically set to p@r@n0!d mode, which is not a bad thing. That was limiting execution of some scripts in WPMU DEV Dashboard. Thus, too restrictive.

    These defines are just a bit low and will cause slow performance.

    @ini_set('memory_limit','275M');
    @ini_set('max_execution_time','30');
    @ini_set('mysql.connect_timeout','30');

    More reasonable values would be:

    @ini_set('memory_limit','512M');
    @ini_set('max_execution_time','180');
    @ini_set('mysql.connect_timeout','180');

    The site will probably still function OK with the lower values, but you may have some "Out of Memory" PHP errors and failed MySQL operations. So, it would be advisable to update those values a bit.

    I hope this clarifies a bit.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.