I'm trying to do a Snapshot but always fails

It takes hours and at some random point it displays an error “we couldn’t find what we were looking for”. I’ve tried 4 times and I always get the same result.

  • Kasia Swiderska
    • Support nomad

    Hello Patrick,

    Huh. I have to admin that this is strange error message and I don’t recall seeing it before.

    Would you mind allowing support access so we can have a closer look at this? I tested now managed backups and snapshots on my site and I could not replicate this issue.

    To enable support access you can follow this guide here:

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,

    Kasia

  • apurba_podder
    • Site Builder, Child of Zeus

    Hello Patrick,

    Hope You are doing good .

    I have seen your WP memory limit is 40M & max execution time 120 . Please increase memory limit. This is more than likely what is causing the timeout error. The backup would be so big that it times out before completing. Could you please try increasing this limit to 400-500 to see if this makes an improvement? This article will help you to increase memory limit & execution time. Your current limits can be found in WPMU DEV -> Support -> System Info.

    Let us know how it went!

    Kind Regards,

    Apurba

  • Nithin
    • Support Wizard

    Hi Patrick,

    That error points out your server was down temporarily, it seems like the support access got expired. Could you please enable support access, so that I could give a closer look at this, and help guide you better.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Kasia Swiderska
    • Support nomad

    Hello Patrick,

    Could you get for us server logs so we could check those errors there (you might need to ask hosting provider where to get them). I would also like to see the debug.log in WordPress after taking failed Snapshot. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    I would need then to see content of the debug.log file – so please upload it to service like a Dropbox and paste link here.

    kind regards

    Kasia

  • Patrick
    • Flash Drive

    I enabled the debug log and tried to run a Snapshot, it displayed a success message but the resulting ZIP is only 53MB, so I tried once again and while saving the post meta I got the following message:

    table_data not set. This normally means that PHP on your server is not properly setup to handle _SESSION. Check with your hosting company.

  • apurba_podder
    • Site Builder, Child of Zeus

    Hello Patrick,

    table_data not set. This normally means that PHP on your server is not properly setup to handle _SESSION. Check with your hosting company.

    Please ask your hosting provider to check session is working properly or not? From debug log I can see that most of the error occurred because of your active theme. Please change your active theme try to take a backup with Snapshot.

    Please let us know how it went. Take care :slight_smile:

    Best Regards,

    Apurba

  • Patrick
    • Flash Drive

    Hey, those errors were generic because of the lack of free space.

    This is what we’ve done so far:

    – We cleaned up the server in order to achieve more than double the space needed for the backup + the temporary files.

    – We tried to create Managed Backups twice, the main ZIP reached almost 4GB but the process ended without a notice (we estimate the final ZIP should be around 12GB).

    Here’s the server log. It seems to be trying to backup content from the phpmyadmin directory.

    The last 4 lines are related to failed updates… which we should also address.

    https://drive.google.com/open?id=0B9OEbNSbgcSUMUlVdElwY04zbGs

  • Nithin
    • Support Wizard

    Hi Patrick,

    Thank you for sharing the log file, unfortunately it doesn’t give a clue regarding what could have gone wrong with Managed backups. Server logs error are mostly related to failed update issues. And the last 4 lines mentions that your server is denying access, would recommend you to get in touch with your host with the server logs to get that sorted faster.

    If you still have issues with updating plugins, would recommend you to create a new thread related to this so that one of the support staffs could give a closer look. Please follow this link to create new thread:

    https://premium.wpmudev.org/forums/#question

    We tried to create Managed Backups twice, the main ZIP reached almost 4GB but the process ended without a notice (we estimate the final ZIP should be around 12GB).

    I’m afraid, at the moment you can only create Managed Backups up to 10 GB in size, so that may be one of the reasons for the backups to not finish.

    You’ll have to either clean up your server so that the estimate ZIP is below 10GB, or you can buy additional cloud storage for the Managed backups above 10 GB. You can find the option to add more space in the Hubs Account page:

    https://premium.wpmudev.org/hub/account/

    Once you have cleaned up the server ie below 10 GB, and if you still have issues with Managed Backups, then please send us your credentials, so that we could give a closer look.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    – To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas

    -WordPress admin username

    -WordPress admin password

    -login url

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Kasia Swiderska
    • Support nomad

    Hello Patrick,

    I’m checking your site now and managed backups are disabled because Key is missing. Can you add that key there so they will be active again.

    You said that we can’t give us FTP because SSH is used. If there will be need to bring developer we will need access to your server so can you consider this again?

    kind regards,

    Kasia

  • Nithin
    • Support Wizard

    Hi Patrick,

    How do I send over the PEM file + credentials?

    Sorry for the delay in getting back to you. I do understand it's taking more time to get this working, but we'll have to have access to FTP in order to troubleshoot it further. You can send the credentials the same way as before.

    Also, please do make sure to activate Managed Backup by entering the key as shown:

    Please do let us know once you have made the required changes, so that we could give a closer look. Have a nice day ahead :slight_smile:

    Best Regards,

    Nithin

  • Nithin
    • Support Wizard

    Hi Patrick,

    Sorry for the delay in getting back to you, I’m afraid, I’m not able to login via the given SSH access. I have asked one of my colleagues to give a closer look, and she wasn’t able to make it work. Maybe I’m missing something here, am I missing any step in making it work?

    Is there any passphrase required? It’s asking a passphrase when trying to save a key? For a faster access, if possible please do setup a SFTP login, so that we could give a closer look at this issue.

    Could you please double check whether the given credentials works in your side too? If you still want us to make use of the existing login info, please advise the steps for connecting with your server. You can send any info, or attach any file regarding this by sending an email directly to: contact@wpmudev.org

    Please let us know that goes, and we’ll make to get back to you asap. Have a nice day ahead. :slight_smile:

    Best Regards,

    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.