I'm trying to get

I'm trying to get the Events+ plugin to display events from a Google calendar so a client can simply add events from their phone...is this possible?

On the Events+ (https://premium.wpmudev.org/project/events-plus/) page, it mentions...

"You can even pull events from other popular calendars with import from Google Calendar and Meetup.com."

I can't seem to find any instructions on how to accomplish this...other than setting up the Google API. Any help would be greatly appreciated. Thanks!

  • Nithin
    • Support Wizard

    Hi anthemwild,

    Hope you are doing good today. :slight_smile:

    Yes, you can import events from Google Calendar. You'll have to enable the Import: Google Calendar add-on, under Events > Settings > Add-ons, and follow the instructions to setup in Events > Settings > Google Calendar import settings.

    If you have successfully configured the settings, once you have authenticated it, the plugin will automatically import events, we have noted that it can take some times 45 min-1 hours, to see the imported events in your plugin. Please do note that, if an event is previously imported, it won't re-import/update the existing ones.

    If you are still having issue even after following the above instructions, would recommend you to please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart), and rule out whether any plugin is causing this issue.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If plugin conflict test doesn't help, please enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska
    • Support nomad

    Hello anthemwild,

    Google changed its console looks at least twice in past few months. It is surprise every time when I go there :wink:

    1) First create new project here https://console.developers.google.com/iam-admin/projects?authuser=1

    2) After that it will open API screen where you will find Calendar

    3) Click in Calendar and then Enable it.
    4) You will see alert with button "Go to credentials" - click on it
    5) There will be screen to help you choose credentials - fill it like that and it should automatically open Oauth credentials. On OAuth consent screen just fill name of the app and that will be enough.

    6) On Create client ID screen choose "Web application" and fill field "Authorized JavaScript origins" with your site url

    7) Last step is Client ID and Client Secret - they will open in popup and you have to copy them to your Events+ settings. You have to be careful with spaces before and after key as this is very common reason for future errors.

    Let me know if you have more questions.

    kind regards,
    Kasia

  • anthemwild
    • WPMU DEV Initiate

    Thank you SO much Kasia!

    Everything works great...except I'm getting an authorization error when trying to authorize from the plugin. Here's the code I'm getting...

    400. That’s an error.
    
    Error: invalid_request
    
    Invalid parameter value for redirect_uri: Non-public domains not allowed: http://jjs-160723-1.kbox/wp-admin/admin-ajax.php?action=eab_gcal_oauth
    
    Learn more
    
    Request Details
    access_type=offline
    scope=https://www.googleapis.com/auth/calendar.readonly
    response_type=code
    redirect_uri=http://jjs-160723-1.kbox/wp-admin/admin-ajax.php?action=eab_gcal_oauth
    state=Eab_Gcal_Plugin_Oauth
    client_id=305454909352-ic0tucgfkrjb2dgeooh8ht35dk7l3s1p.apps.googleusercontent.com
    That’s all we know.

    And when I put in the Authorized Redirect URI from Step 3 of the Google add-on (http://mysitename.com/wp-admin/admin-ajax.php?action=eab_gcal_oauth...it won't let me add it. It's saying...

    Invalid Redirect: http://mysitename.com/wp-admin/admin-ajax.php?action=eab_gcal_oauth must end with a public top-level domain (such as .com or .org)

    Weird.

  • Kasia Swiderska
    • Support nomad

    Hello anthemwild,,

    I checked again and I was wrong in point 6 in previous answer (I'm sorry for that). This is how the credentials should look like

    So only "Authorized redirect URIs" has to be filled.

    But back to your error - your site is not accessible (I'm checking domain of site that is related to that thread) so it will not work with google. Error says "Non-public domains not allowed" - so until your site will be live you cannot use that Google Service I'm afraid.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.